
Introduction 
Microsoft Excel 2013 is a spreadsheet program that is used to manage, analyze, and present data. 
It includes many powerful tools that can be used to organize and manipulate large amounts of 
data, perform complex calculations, create professional-looking charts, enhance the appearance 
of worksheets, and more. This handout provides an overview of the Excel 2013 user interface 
and covers how to perform basic tasks such as starting and exiting the program; creating, saving, 
opening, and closing workbooks; selecting cells; entering and editing data; formatting text and 
numbers; positioning cell contents; applying cell styles; and getting help. 

Starting Excel 
You can start Excel 2013 from the Start menu (in Windows 7) or by double-clicking an existing 
Excel file. When you start the program without opening a specific file, the Start screen appears, 
prompting you to open an existing workbook or create a new workbook. 
 
To start Excel 2013 from the Start menu: 

1. Click the Start button, click All Programs, click Microsoft Office 2013, and then click 
Excel 2013. The Start screen appears (see Figure 1). 

2. In the right pane, click Blank workbook. A new, blank workbook opens in the program 
window. 

 
Figure 1 – Excel 2013 Start Screen 

Overview of the User Interface 
All the Microsoft Office 2013 programs share a common user interface so you can apply basic 
techniques that you learn in one program to other programs. The Excel 2013 program window is 
easy to navigate and simple to use (see Figure 2 and Table 1). 



 
Figure 2 – Excel 2013 Program Window 

Table 1 – Excel 2013 Program Window Elements 

Name Description 
Title bar Appears at the top of the program window and displays the name of the 

workbook and the program. The buttons on the right side of the Title bar are 
used to get help; change the display of the Ribbon; and minimize, restore, 
maximize, and close the program window. 

Quick Access 
toolbar 

Appears on the left side of the Title bar and contains frequently used commands 
that are independent of the tab displayed on the Ribbon. 

Ribbon Extends across the top of the program window, directly below the Title bar, and 
consists of a set of tabs, each of which contains groups of related commands. 

Formula bar Appears below the Ribbon and displays the data or formula stored in the active 
cell. It can also be used to enter or edit cell contents. 

Name box Appears on the left side of the Formula bar and displays the active cell address 
or the name of the selected cell, range, or object. 

Workbook 
window 

Appears below the Formula bar and displays a portion of the active worksheet. 

Sheet tab Each worksheet has a tab that appears below the workbook window and 
displays the name of the worksheet. 

Scroll bars Appear along the right side and bottom of the workbook window and enable 
you to scroll through the worksheet. 

Status bar Appears at the bottom of the program window and displays the status of Excel 
(such as Ready). The tools on the right side of the Status bar can be used to 
display the worksheet in a variety of views and to change the zoom level. 



Ribbon 
The Ribbon is designed to help you quickly find the commands that you need to complete a task. 
It consists of a set of task-specific tabs (see Figure 3 and Table 2). The standard tabs are visible 
at all times. Other tabs, known as contextual tabs, appear only when you create or select certain 
types of objects (such as images or charts). These tabs are indicated by colored headers and 
contain commands that are specific to working with the selected object. Clicking a tab displays a 
set of related commands that are organized into logical groups. Commands generally take the 
form of buttons and lists; some appear in galleries. Pointing to an option in most lists or galleries 
displays a live preview of that effect on the selected text or object. You can apply the previewed 
formatting by clicking the selected option, or you can cancel previewing without making any 
changes by pressing the Esc key. Some commands include an integrated or separate arrow. 
Clicking the arrow displays a menu of options available for the command. If a command on the 
Ribbon appears dimmed, it is unavailable. Pointing to a command on the Ribbon displays its 
name, description, and keyboard shortcut (if it has one) in a ScreenTip. 
 
A dialog box launcher  appears in the lower-right corner of most groups on the Ribbon (see 
Figure 3). Clicking it opens a related dialog box or task pane that offers additional options or 
more precise control than the commands available on the Ribbon. 
 
You can collapse the Ribbon by clicking the Collapse the Ribbon button  on the right side 
of the Ribbon (see Figure 3) or by double-clicking the current tab. When the Ribbon is collapsed, 
only the tab names are visible. You can expand the Ribbon by double-clicking any tab. 

 
Figure 3 – Ribbon 

Table 2 – Ribbon Tabs 

Name Description 
File Displays the Backstage view which contains commands related to managing files 

and customizing the program. 
Home Contains the most frequently used commands. The Home tab is active by default. 
Insert Contains commands related to all the items that you can insert into a worksheet. 
Page Layout Contains commands that affect the overall appearance and layout of a worksheet. 
Formulas Contains commands used to insert formulas, define names, and audit formulas. 
Data Contains commands used to manage data and import or connect to external data. 
Review Contains commands used to check spelling, track changes, add comments, and 

protect worksheets. 
View Contains commands related to changing the view and other aspects of the display. 



Quick Access Toolbar 
The Quick Access toolbar provides one-click access to commonly used commands and options. 
By default, it is located on the left side of the Title bar and displays the Save, Undo, and Redo 
buttons (see Figure 4). You can change the location of the Quick Access toolbar as well as 
customize it to include commands that you use frequently. 

 
Figure 4 – Quick Access Toolbar 

 
To add a command to the Quick Access toolbar: 

1. On the Ribbon, right-click the command 
that you want to add, and then click Add 
to Quick Access Toolbar on the shortcut 
menu. 

 
To remove a command from the Quick Access 
toolbar: 

1. On the Quick Access toolbar, right-click 
the command that you want to remove, and 
then click Remove from Quick Access 
Toolbar on the shortcut menu. 

 
NOTE: Clicking the arrow on the right side of the 
Quick Access toolbar displays a menu which includes 
additional commands and options that can be used to 
customize the toolbar. A check mark next to an item 
indicates that the item is selected (see Figure 5).  

Figure 5 – Customize Quick Access 
Toolbar Menu 

Mini Toolbar 
The Mini toolbar provides quick access to 
frequently used commands and appears 
whenever you right-click a cell or an object 
(see Figure 6).  

Figure 6 – Mini Toolbar 

Shortcut Menus 
Excel 2013 includes many shortcut menus that appear when you right-click an item. Shortcut 
menus are context-sensitive, meaning they list commands that pertain only to the item that you 
right-clicked (see Figure 7). 

 
Figure 7 – Ribbon Shortcut Menu 



Backstage View 
The File tab (the first tab on the Ribbon) is used to display the Backstage view which contains all 
the commands related to managing files and customizing the program. It provides an easy way to 
create, open, save, print, share, export, and close files; view and update file properties; set 
permissions; set program options; and more. Commands available in the Backstage view are 
organized into pages which you can display by clicking the page tabs in the left pane. 
 
To display the Backstage view: 

1. Click the File tab on the Ribbon (see Figure 8). 

 
Figure 8 – File Tab 

To exit the Backstage view: 
1. Click the Back button in the upper-left corner of the Backstage view (see Figure 9). Or, 

press the Esc key. 

 
Figure 9 – Info Page of the Backstage View 

Formula Bar 
The Formula bar displays the contents of the active cell and can be used to enter or edit cell 
contents. The Formula bar contains three buttons (see Figure 10). The Insert Function button is 
always available, but the other two buttons are active only while you are entering or editing data 
in a cell. Clicking the Cancel button cancels the changes you make in the cell, which is the same 
as pressing the Esc key. Clicking the Enter button completes the changes you make in the cell, 
which is the same as pressing the Enter key. Clicking the Insert Function button opens a dialog 
box that helps you construct formulas. 



 
Figure 10 – Formula Bar 

Overview of Workbooks 
An Excel file is called a workbook. Each new workbook contains one blank worksheet (see 
Figure 11). You can add additional worksheets or delete existing worksheets as needed. By 
default, a new workbook is named Book1 and the worksheet it contains is named Sheet1. Each 
worksheet consists of 1,048,576 rows (numbered 1 through 1,048,576) and 16,384 columns 
(labeled A through XFD). The box formed by the intersection of a row and a column is called a 
cell. Cells are used to store data. Each cell is identified by its address which consists of its 
column letter and row number (e.g., cell A1 is the cell in the first column and first row). A group 
of cells is called a range. A range is identified by the addresses of the cells in the upper-left and 
lower-right corners of the selected block of cells, separated by a colon (e.g., A1:C10). Only one 
cell can be active at a time. The active cell has a green border around it and its address appears in 
the Name box on the left side of the Formula bar. The row and column headers of the active cell 
appear in a different color to make it easier to identify. A worksheet also has an invisible draw 
layer which holds charts, images, and diagrams. 

 
Figure 11 – Worksheet 

Creating Workbooks 
When you start Excel 2013 and click Blank workbook on the Start screen, a new workbook 
opens in the program window, ready for you to enter your data. You can also create a new 
workbook while Excel 2013 is running. Each new workbook displays a default name (such as 
Book1, Book2, and so on) on the Title bar until you save it with a more meaningful name. 
 



To create a new workbook: 
1. Click the File tab, and then click New. The New page of the Backstage view opens, 

displaying thumbnails of the available templates (see Figure 12). 
2. In the right pane, click Blank workbook. A new, blank workbook opens in a new 

window. 
NOTE: You can also create a new workbook by pressing Ctrl+N. 

 
Figure 12 – New Page of the Backstage View 

Saving Workbooks 
After creating a workbook, you can save it on your computer. Use the Save As command when 
you save a workbook for the first time or if you want to save a copy of a workbook in a different 
location, with a different file name, or in a different file format. Use the Save command to save 
changes to an existing workbook. 
 
NOTE: Excel 2013’s file format is called Excel Workbook and is the same as Excel 2007 and 2010. This 
format has the .xlsx file extension and is not backward compatible with Excel versions prior to 2007. You 
can use Excel 2013 to save a workbook in the Excel 97-2003 Workbook format with the .xls file extension 
to make it compatible with earlier versions of Excel, but you will not have access to all of Excel 2013’s 
features. 
 
To save a workbook for the first time: 

1. Click the File tab, and then click Save As. The Save As page of the Backstage view 
opens (see Figure 13). 

2. Click Computer in the center pane, and then click the Browse button or a recent folder 
in the right pane. 



 
Figure 13 – Save As Page of the Backstage View 

3. In the Save As dialog box, select a location to save the file, type a name in the File name 
box, and then click the Save button (see Figure 14). 
NOTE: By default, Excel 2013 workbooks are saved in the Excel Workbook format. To save a 
document in a different format, click the Save as type arrow and select the desired file format 
from the list. 

 
Figure 14 – Save As Dialog Box 



To save changes to a workbook: 
1. Do one of the following: 

 Click the File tab, and then click Save. 

 On the Quick Access toolbar, click the Save button . 
 Press Ctrl+S. 

Closing Workbooks 
When you finish working on a workbook, you can close it, but keep the program window open to 
work on more workbooks. If the workbook contains any unsaved changes, you will be prompted 
to save the changes before closing it. 
 
To close a workbook without exiting Excel: 

1. Click the File tab, and then click Close. Or, press Ctrl+W. 

Opening Workbooks 
You can locate and open an existing workbook from the Start screen when Excel 2013 starts or 
from the Open page of the Backstage view. The Start screen and the Open page also display a list 
of recently used workbooks which you can quickly open by clicking them. Each workbook opens 
in its own window, making it easier to work on two workbooks at once. 
 
To open a workbook: 

1. Click the File tab, and then click Open. Or, press Ctrl+O. The Open page of the 
Backstage view opens, displaying a list of recently used workbooks in the right pane. 

2. If the workbook you want is in the Recent Workbooks list, click its name to open it. 
Otherwise, proceed to step 3. 

3. Click Computer in the center pane, and then click the Browse button or a recent folder 
in the right pane (see Figure 15). 

 
Figure 15 – Open Page of the Backstage View 



4. In the Open dialog box, locate and select the file that you want to open, and then click 
the Open button (see Figure 16). 

 
Figure 16 – Open Dialog Box 

NOTE: When you open a workbook created with earlier versions of Excel in Excel 2013, the workbook 
opens in compatibility mode (indicated on the Title bar) with some of the new features of Excel 2013 
disabled. You can easily convert the workbook to the Excel 2013 file format by clicking the Convert 
button on the Info page of the Backstage view (see Figure 17). 

 
Figure 17 – Convert Button on the Info Page of the Backstage View 

Moving Around and Making Selections 
This section covers how to perform basic tasks such as moving around worksheets and selecting 
cells, rows, and columns. 



Moving Around Worksheets 
There are various ways to navigate through a worksheet. Using the mouse and the scroll bars, 
you can scroll through the worksheet in any direction. Using the navigational keys on the 
keyboard, you can move from cell to cell, move up or down one page at a time, or move to the 
first or last used cell in the worksheet (see Table 3). You can also navigate to a specific cell in 
the worksheet by entering its address in the Name box. 
 
NOTE: Scrolling with the mouse does not change the location of the active cell. To change the active cell, 
you must click a new cell after scrolling. 
 
Table 3 – Navigation Keyboard Shortcuts 

Key Action 
Down arrow or Enter Moves the active cell one cell down.  
Up arrow or Shift+Enter Moves the active cell one cell up. 
Right arrow or Tab Moves the active cell one cell to the right. 
Left arrow or Shift+Tab Moves the active cell one cell to the left. 
Page Down Moves the active cell down one page. 
Page Up Moves the active cell up one page. 
Alt+Page Down Moves the active cell right one page. 
Alt+Page Up Moves the active cell left one page. 
Ctrl+Home Moves the active cell to cell A1.  
Ctrl+End Moves the active cell to the last used cell in the worksheet.  

Selecting Cells, Rows, and Columns 
In order to work with a cell, you must first select it. When you want to work with more than one 
cell at a time, you can quickly select ranges, rows, columns, or the entire worksheet. 
 
To select a single cell: 

1. Click the desired cell (see Figure 18). 

 
Figure 18 – Active Cell 

To select a range of cells: 
1. Click the first cell that you want to include in the range, hold down the Shift key, and 

then click the last cell in the range (see Figure 19). Or, drag from the first cell in the 
range to the last cell. 
NOTE: When a range is selected, every cell in the range is highlighted, except for the active cell. 
You can deselect a range by pressing any arrow key or by clicking any cell in the worksheet. 

 
To select nonadjacent cells or ranges: 

1. Select the first cell or range, hold down the Ctrl key, and then select the other cells or 
ranges (see Figure 20). 



 

 
Figure 19 – Selected Range 

 
Figure 20 – Selected Nonadjacent Ranges 

To select a single row or column: 
1. Click the header of the row or column that you want to select (see Figure 21 and Figure 

22). 
NOTE: When a row or column is selected, every cell in the row or column is highlighted, except 
for the active cell. You can deselect a row or column by pressing any arrow key or by clicking 
any cell in the worksheet. 

 

 
Figure 21 – Selected Row 

 
Figure 22 – Selected Column 

To select multiple adjacent rows or columns: 
1. Click the header of the first row or column that you want to select, hold down the Shift 

key, and then click the header of the last row or column. Or, drag across the headers of 
the rows or columns that you want to select. 

 
To select multiple nonadjacent rows or columns: 

1. Hold down the Ctrl key, and then click the headers of the rows or columns that you want 
to select. 

 
To select all cells in a worksheet: 

1. Click the Select All button in the upper-left corner of the worksheet (see Figure 23). Or, 
press Ctrl+A. 

 
Figure 23 – Select All Button 



Editing Worksheets 
After creating a workbook, you can start adding data to a worksheet. If you need to make 
changes, you can easily edit the data to correct errors, update information, or remove information 
you no longer need. 

Entering Data 
You can add data by entering it directly in a cell or by using the Formula bar. A cell can contain 
a maximum of 32,767 characters and can hold any of three basic types of data: text, numbers, or 
formulas. 
 
NOTE: If you make a mistake while entering data, simply press the Backspace key to delete all or a 
portion of your entry and enter the correct data. 

Entering Text 
You can enter text in a worksheet to serve as labels for values, headings for columns, or 
instructions about the worksheet. Text is defined as any combination of letters and numbers. Text 
automatically aligns to the left in a cell. If you enter text that is longer than its column’s current 
width, the excess characters appear in the next cell to the right, as long as that cell is empty (see 
Figure 24). If the adjacent cell is not empty, the long text entry appears truncated (see Figure 25). 
The characters are not actually deleted and will appear if the width of the column is adjusted to 
accommodate the long text entry. 
 

 
Figure 24 – Overflowing Text Entry 

 
Figure 25 – Truncated Text Entry 

 
To enter text: 

1. Select the cell in which you want to 
enter text. 

2. Type the desired text, and then press 
the Enter key. 
NOTE: To enter a line break in a cell, 
press Alt+Enter (see Figure 26). 

 
Figure 26 – Cell with Line Breaks 

Entering Numbers 
Numeric entries contain only numbers and are automatically aligned to the right in a cell. 
Numbers can exist as independent values, or they can be used in formulas to calculate other 
values. You can enter whole numbers (such as 5 or 1,000), decimals (such as 0.25 or 5.15), 
negative numbers (such as -10 or -5.5), percentages (such as 20% or 1.5%), and currency values 
(such as $0.25 or $20.99). 
 
NOTE: A number that does not fit within a column is displayed as a series of pound signs (#####). To 
accommodate the number, increase the column width. 
 
To enter a number: 

1. Select the cell in which you want to enter the number. 
2. Type the desired number, and then press the Enter key. 
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 Protect sheet – enter a password and protect the entire or a part of a sheet (cell range) 

 Rename Sheet - enter a name and press the Enter key 

 Lock cell – functional only if we protect the worksheet first 

Enter function: 

1. select a cell range  

2. enter a function via menu shown on the right  

Or:  1. select the cell in which you want to enter function value  

 2. enter the symbol „=“ 

 3. enter the function manually (e.g. „sum“), and the cell range to which the function will apply, 

respecting syntax 

 

Most often used functions: 

=SUM(cell range)   adding the numbers in selected cells 

=AVERAGE(cell range)  finds the average value 

=MIN(cell range)   finds the smallest value 

=MAX(cell range)   finds the biggest value 

 

Deleting options: 

 Clear All  

 Clear Contents 

 Clear Formats 

 

Sort A to Z - sort data within a table from minimum to maximum value, or 

Sort Z to A – sort data within a table from maximum to minimum values 

 

 

 Find: enter a word or phrase and press the Find button  

      Replace: - Find What – field to enter the word we are searching for; 

- Replace With - field to enter the word that we want to use as a replacement 

 

Format Painter  - copy formatting from one part of the text to another  

Help in MS Excel  , or F1 on the keyboard 
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INSERTING, DELETING, AND MERGING CELLS 

 
Inserting Cells: 

 

1. Select the cell(s) above or to the left of the  

cells you want to move. 

 

2. Click on the INSERT menu. 

 

3. Click on CELLS.    

 

4. Click on appropriate selection. 

 

5. Click OK. 

  

OR 

 

1. Select the cell(s) above or to the left of the cells you want to move. 

 

2. Right-click. 

 

3. Click on INSERT. 

 

4. Follow steps 3-5 from above. 

 

Inserting Rows and Columns: 

 

1. Select a cell to the left of the column or above the row that will be moved. 

 

2. Click on the INSERT menu. 

 

3. Click on COLUMNS or ROWS 

 

OR 

 

1. Right-click the column or row heading. 

 

2. Follow steps 2-3 from above. 
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Tip 

Click the Undo button to reverse the last change made. To 

“undo the undo” click the Redo button . 

Deleting Cells: 

 

1. Select the cell(s) to delete. 

 

2. Click on the EDIT menu. 

 

3. Click on DELETE.    

 

4. Click on appropriate selection. 

 

5. Click OK. 

 

OR 

 

1. Select the cell(s) to delete. 

 

2. Right-click. 

 

3. Follow steps 3-5 from above. 

 

Deleting Rows and Columns:  

 

1. Select at least one cell in the column or row.   

 

2. Click on the EDIT menu. 

 

3. Click on DELETE 

 

4. Click on appropriate selection. 

 

5. Click OK. 

 

Merging Cells: 

 

1. Select the cells you want to merge. 

 

2. Click the MERGE AND CENTER button 

 on the toolbar. 
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PRINTING WORKSHEETS AND WORKBOOKS 

 
Previewing a Worksheet: 

 

To preview the worksheet before you print it, click the PRINT PREVIEW button . 

 

To exit the Print Preview screen, click on CLOSE. 

 

Setting the Print Area: 

 

1. Select the area of the worksheet that is to be printed. 

 

2. Click on the FILE menu. 

 

3. Click on PRINT AREA. 

 

4. Click on SET PRINT AREA. 

 

Clearing the Print Area: 

 

1. Click on the FILE menu. 

 

2. Click on PRINT AREA. 

 

3. Click on CLEAR PRINT AREA. 

 

Printing: 

 

1. Click on the FILE menu. 

 

2. Click on PRINT. A dialog box  

will appear. 

 

3. Select the options you wish to change  

(page name, name of printer, etc.) 

 

4. Select the number of copies. 

 

5. Click OK.   

 

 

OR 

 

1. Click the PRINT button  on the toolbar. 
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Copying a Formula: 

 

1. Select the cell with the formula you want to copy. 

 

2. Point to the fill handle. 

 

3. Move the fill handle to the last cell in the range. 

 

     

     

     

     

     

            

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Editing a Formula: 

 

1. Click on the appropriate cell. 

 

2. Position the insertion point in the FORMULA BAR, or click on the 

EDIT FORMULA button  on the formula bar. 

 

3. Make the changes and press ENTER. 

 

Deleting a Formula: 

 

1. Click on the appropriate cell 

 

2. Press DELETE. 

 

Fill Handle 

Tip 
The fill handle can be used to complete a series of years, 

dates, days, etc. 
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MOVING DATA 
 

Cutting, Copying, and Pasting : 

  
 Cutting text removes data from a cell while copying duplicates the data so that it can be 

pasted to another location. 

 

1. Select the cell(s) that contain the data to be cut or copied. 

 

2. Click on the CUT or COPY button.    

 

3. Select the cell(s) where the data will be pasted. 

 

4. Click on the PASTE button.  

 

 

Copying Data Using the Fill Handle: 

 

1. Select the cell(s) that contain the data to be copied. 

 

2. Drag the fill handle to the desired cells.  

 

 

Paste Special: 

 
Paste Special allows you to choose which parts of a cell you want to paste. You can paste only the  

cell’s formatting, formula, or width if desired. 

 

1. Select the cells that you want 

to cut or copy. 

 

2. Click on the CUT or COPY button. 

  

 

3. Select the cell(s) where the data 

will be pasted. 

 

4. Click on the EDIT menu. 

 

5. Click on PASTE SPECIAL 

 

6. Click on the desired pasteoption. 

 

7. Click OK. 
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FIND AND REPLACE 
 

Find: 

 

1. Go to the beginning of the document  

by pressing [Ctrl] [Home]. 

 

2. Click on the EDIT menu.   

 

3. Click on FIND. 

 

4. Click on the FIND tab in the dialog 

box that opens. 

 

5. Enter the word or number you wish to find in the “FIND WHAT” text 

box. 

 

6. Click on the SEARCH drop-down menu and click on rows or columns. 

 

7. Click on the LOOK IN drop-down menu and click on formulas, values, 

 or comments. 

 

8. Click on FIND NEXT. 

 

9. Click OK when finished. 
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Replace: 

 

1. Repeat steps 1thru 3 from above. 

 

2. Click on the REPLACE TAB in 

 the dialog box that opens. 

 

3. Enter the word or number you wish 

 to find in the “FIND WHAT” text box. 

 

4. Enter the word or number you wish to 

 replace it with in the “REPLACE WITH” 

 text box. 

 

5. Click on the SEARCH drop-down menu 

 and click on rows or columns. 

 

6. Click on REPLACE ALL to replace every occurrence. 
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ADDING HEADERS AND FOOTERS 

 

 
1. Click on the VIEW menu. 

 

2. Click on HEADER AND FOOTER. 

 

3. Click on the header or footer drop-

down menu and select the desired 

header and footer. 

 

4. Click OK. 

 

 

 

Customizing Headers and Footers: 

 

1. Repeat steps 1 & 2 from above. 

 

2. Click on the CUSTOM HEADER or CUSTOM FOOTER button. 

 

 

            

   

 

 

 

3. Type desired text and field codes into the appropriate sections. 

 

4. Click OK in the Header/Footer dialog box. 

 

5. Click OK in the Page Setup dialog box.  

 

 

 

Font Button Total Pages Button 

Page Number Button Date Button 

Time Button 

File Name Button 

 

Sheet Name Button 



 27 

MAKING CHANGES TO THE PAGE LAYOUT 
 

 

Changing Margins: 

 

1. Click on the FILE menu.   

 

2. Click on PAGE SETUP. 

 

3. Click on the MARGINS tab. 

 

4. Change the margins by clicking 

 on the arrows or typing a new  

 setting into the text box. 

 

5. Click OK. 

 

 

Inserting and Deleting Page Breaks: 

 

Insert 
1. Select a cell below and to the right of where you want the page break to be added. 

 

2. Click on the INSERT menu. 

 

3, Click on PAGE BREAK. 

 

Delete 
1. Follow steps 1 & 2 from above. 

 

2. Click on REMOVE PAGE BREAK. 

 

Previewing Page Breaks: 

 

1. Click on the VIEW menu. 

 

2. Click on PAGE BREAK PREVIEW. 
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5. FORMATTING CONT.

Figure 10. Inserting Rows

Figure 11. Inserting Columns

Figure 12. Charts Tab

Adding Rows and Columns

Rows are cells that run horizontally across the document.  You can insert an extra row of cells like this:

1.  Drag select along the row of cells where you want your new row to appear.
2.  Click Home Tab > Insert > Insert Sheet Rows. (Figure 10).The row will automatically be 	   	
placed on the spreadsheet and any data that was selected in the original row will be moved down below 
the new row.

Working With Charts

Charts are an important part to being able to create a visual for spreadsheet data. 

1.  In order to create a chart within Excel the data that is going to be used for it needs to be entered 
already into the spreadsheet document. Once the data is entered, the cells that are going to be used for 
the chart need to be highlighted so that the software knows what to include. Next, click on the Insert 
Tab that is located at the top of the screen. (Figure 12)

Columns are cells that run vertically down the document.  You can insert an extra column of cells like 
this:

1.  Drag select along the column of cells where you want your new column to appear.
2.  Go to Home Tab > Insert > Insert Sheet Column.The column will automatically be place on the 
spreadsheet and any data to the right of the new column will be moved more to the right. (Figure 11)



5. FORMATTING CONT.
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Figure 13. Chart in new sheet

Figure 14. Design Tab for chart design.

2.  You may choose the chart that is desired by clicking the category of the chart you will use. 
Once the category is chosen the charts will appear as small graphics within a drop down menu. 		
To choose a particular chart just click on its icon and it will be placed within the spreadsheet you are 
working on. 

3.  To move the chart to a page of its own, select the border of the chart and Right Click. This will bring 
up a drop down menu, navigate to the option that says Move Chart. This will bring up a dialog box that 
says Chart Location. From here you will need to select the circle next to As A New Sheet and name 
the sheet that will hold your chart. The chart will pop up larger in a separate sheet but in the same 
workbook as your entered data. (Figure 13)

Chart Design

There are features that you can change to make your chart more appealing. To be able to make these 
changes you will need to have the chart selected or be viewing the chart page that is within your 
workbook. Once you have done that the Design Tab will appear highlighted with various different 
options to format your graphic. (Figure 14)
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5. FORMATTING CONT.

6. INSERTING SMART ART GRAPHICS

Figure 15. Inserting Clip Art

Chart Options

Titles:  Within the new chart Design tab, click the Add Chart Element icon. Here, you will see the option 
to title the chart as well as various components of the chart. 

Change Chart Type:  You can change your chart easily by selecting this icon and navigating to a more 
desirable chart. This feature is very convenient for someone who chose the wrong chart and doesn’t 
wish to reselect all their data and go through the process a second time.

Format Chart Area: This allows for changes to be made to the chards border, style, fill, shadows, and 
more. To get this option you will need to right click on the charts border and navigate to the Format 
Chart Area option. Once this is clicked a dialog box will appear.

Pictures

To insert Pictures:
Go to the Insert Tab> Picture, a dialog box will appear and then you can select the desired picture from 
the location that is it stored. The picture will be inserted directly onto your document, where you can 
change the size of it as desired.

Inserting Clipart:
To insert Clip Art you will need to go to the Insert Tab > Online Pictures.  A window will appear giving 
you the options to either pull clip art from the Microsoft Office website or search for more options 
using a Bing image search engine. (Figure 15)
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6. INSERTING SMART ART GRAPHICS CONT.

Figure 17. Choosing calculation cell

Figure 18. First calculation display

Creating Functions

When creating a function in Excel you must first have the data that you wish to perform the function 
with selected. 

1.  Select the cell that you wish for the calculation to be entered in (i.e.: if I want to know the 		                
sum of B1:B5 I will highlight cell B6 for my sum to be entered into). (Figure 17)

 2.  Once you have done this you will need to select the Formulas Tab located at the top of the screen.
 3.  A list of Most Recently Used, Financial, Logical, Text, Date and Time, Math and Trig formulas will 
 appear. To choose one of the formulas click the icon that holds the formula you are looking for. 
 4.  Once you have clicked your formula this will display a dialog box on your screen. (Figure 18)

In this screen it lists the cells that are being calculated, the values within the cells, and the end result.

5.  To accept that calculation you can press OK and the result will show up in the selected cell.
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7. PRINTING

8. OTHER HELPFUL FUNCTIONS

It is important to always save your document before you print!

Printing

To print your document, go to File Tab > Print, select your desired settings, and then click OK. You can 
also do this by using the shortcut CTRL + P

To be able to change the orientation of your page for printing you can click on the Portrait Orientation 
button under the option under Print then click the change the layout. (Figure 19)

Undo and Redo

In order to undo an action, you can click on the blue arrow icon that is pointing to the left at the top of 
the screen. To redo an action, you can click on the blue arrow icon pointing to the right. It is important 
to note that not all actions are undoable, thus it is important to save before you make any major changes 
in your document so you can revert back to your saved document. (Figure 20)

Quitting

Before you quit, it’s a good idea to save your document one final time. You will need to double click the 
the Excel icon in the upper lefthand corner.This is better than just closing the window, as it insures your 
document quits correctly.

Figure 19. Page Setup 
button and printing

Figure 20. Undo/Redo butons 
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Insert tab 

 

Shapes  – after selecting a shape, we can insert it in the sheet using the drag-and-drop method, which 

automatically defines its size and position. 

Arrange – sets elements in front of (option Bring forward) or behind (option Send to back) other elements. 

   - opens color palette 

                     - opens color palette and options for choosing type and thickness of lines 

          - effects: 3D, shadow, reflection, rotation etc. 

 

Pictures  

 to select a picture: press the left mouse button on it, the picture will get squares on the border called 

control points which allows the size of the image to be manipulated. 

 set object size: 

o manually: select an object, move some of the control points using the drag-and-drop method 

o enter values: press the right mouse button on the object and choose the Format Picture option; on 

the Size tab, enter values for height and width 

 

While the object is selected, we can open the Format tab, that contains some new formatting options 

  - Corrections - tool for contrast, brightness, sharpness correction   

  - Color - change color of the images in order to better match the rest of the content 

  - Artistic effects - tools that can make an image  appear as if it was a drawing or painting 

 

- tool for inserting a text box; after selecting this tool, we can set the position and the size of the text 

box in the worksheet via the drag-and-drop method 

 

Header and Footer - edit: press the left mouse button within the header or footer field, or: press the right 

mouse button and from the quick menu, choose the Edit Text option 

 

        - insert date and time 

        - insert page number 
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Insert symbol     €   £   ©  ∞    ≠                etc. 

 

Chart     

Charts are graphical representaitons of table data in various forms, like column graph. Tabular data and graph 

are connected - therefore changes in the table are reflected in the chart 

 when we insert a chart, a table for data entry opens in Microsoft Excel and we can enter data. Also, if 

we select a cell range filled with data, the chart will be automatically filled with the selected data. 

 to change chart size: select a chart and move (drag-and-drop) the control points to the desired 

direction 

 changes in the chart can be done via the Chart Tools toolbar, that appears when the chart is selected; 

via the quick menu or by double-click with the left mouse button on the chart 

o Format Chart Area – effects like color fill, 3D, rotation, shadow etc. are accessible 

o Change Chart Type – choose chart type  

 move the chart: within the Chart Tools toolbar, select the Design and choose tool Move chart: 

> New sheet (and there is a field to enter the worksheet's name), or 

> Object in > on the drop-down menu, choose the worksheet in which you want to place the 

chart 

 

 

 „SmartArt“  

 fields can be moved in order to edit its structure: press the left mouse button on the fields border, via 

the drag-and-drop method, move it to the desired position 

 add new field: press the right mouse button over the field, upon which you want to add a new field 

and choose the Add Shape option on the quick menu, then choose where to add it “below” or “above” 

(hierarchal)   

 deleting: select a field and press the Delete button 

 

Sparklines  

 chart within one cell;  

 needs to have a defined position (cell address that contains it) and data cell 

range (data to display)  
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Tab name: Page Layout 

 

The Page Layout settings change the look of the Excel file when it is printed.  

Margins:  - Normal - Narrow - Wide 

Orientation: Portrait (vertical) and Landscape (horizontal)   

Scale: tool for fitting data for print to a paper 

Breaks – it is recommended that user sets the breaks manually:  

 Insert Page Break 

 Remove Page Break 

Tools for organizing content:  - Bring Forward 

    - Send Backward 

 

Review tab 

 

Spelling  - opens a dialog box with options: Ignore once, Ignore all, Change, Change all 

 the word that is not in the dictionary can be added: press the right mouse button over it and choose the 

Add to dictionary option 

 

View tab 

 

Normal - for creating a worksheet 

Page Layout – for print preview of the data set for printing, header and footer 

  

Zoom – choose offered or enter value 
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Freeze and unfreeze rows and columns in order to always be visible. This is useful when the data in the 

worksheet does not fit on the computer screen but the user needs to see the row and column labels: 

 freezing columns and rows: select a cell within the sheet and choose the Freeze Panes button. 

Columns to the left and rows above will be “frozen” meaning that as the user scrolls left and right in 

the worksheet, the frozen cells always remain visible. 

 freezing top row: choose the Freeze Panes button and choose  freeze top row 

 freezing first column: choose the Freeze Panes button and choose freeze first column 

 

FORMULAS 

 

Formula uses numerical data found in the chosen cell range (the value entered in a cell range) 

 

Enter the formula: 

1. select the cell where you want to enter a formula 

2. enter the sign „=“ 

3. enter numeric values or cell addresses  and arithmetic operator 

4. press the Enter key to complete 

 

Basic arithmetic operators: 

 addition  = A1 + A2 

 multiplication  = A3 * C5 

 division  = C5/C3 

 exponentiation  = F15^ A2 

Microsoft Excel follows the mathematical order of calculation operations. 

Formula can be seen in the formula bar when the cell, that contains it, is selected or if we position the cursor 

with a double click in the cell, that contains the formula (that way it will be visible in the cell and edited too). 

The formula result will be displayed in the cell that contains the formula and where the cursor is not 

positioned. 

Relative cell referencing (e.g. C5) 

 when the formula is copied with  AutoFill and it has relative cell references, cell references are going 

to adapt, for example: 

If we use Auto fill to copy the following formula: =C5+B5, it will change to: =C6+B6, =C7+B7 etc. 
 

Absolute cell referencing (e.g. $C$5) 

If the cell is referenced absolutely in a formula, then applying the Auto fill tool will result in: 

=$C$5+B5, =$C$5+B6, =$C$5+B7 etc. 

 

You can change the selected cell reference from relative to absolute and vice versa by using the F4 key 
 

 

Logical function if  

= logical function that compares cell values with some expression or value. We define the appropriate 

action depending on the result 



Entering Dates and Times  
Excel treats dates and times as special types of numeric values. 
 
To enter a date: 

1. Select the cell in which you want to enter the date. 
2. Type the month, day, and year, with each number separated by a forward slash (/) or a 

hyphen (-), and then press the Enter key. 
 
To enter a time: 

1. Select the cell in which you want to enter the time. 
2. Type the hour, a colon (:), and the minutes, press the Spacebar, type a for A.M. or p for 

P.M., and then press the Enter key. 

Editing Data 
If a cell contains a long entry and you only want to change a few characters, it is faster to edit the 
data than to retype the entire entry. You can edit the contents of a cell directly in the cell or by 
using the Formula bar. 
 
To edit data: 

1. Double-click the cell that contains the data you want to edit. The cursor (a blinking 
vertical line) appears in the cell in the location that you double-clicked. 

2. To insert characters, click where you want to make changes, and then type the new 
characters. 
NOTE: You can also move the cursor by pressing the Home, End, or arrow keys. 

3. To delete characters, click where you want to make changes, and then press the 
Backspace or Delete key. 
NOTE: Pressing the Backspace key deletes the character to the left of the cursor; pressing the 
Delete key deletes the character to the right of the cursor. 

4. When you are finished, press the Enter key. 
NOTE: If you are editing data and decide not to keep your edits, press the Esc key to return the 
cell to its previous state. 

Replacing Data 
You can replace the entire contents of a cell with new data. Any formatting applied to the cell 
remains in place and is applied to the new data. 
 
To replace data: 

1. Select the cell that contains the data you want to replace. 
2. Type the new data, and then press the Enter key. 

Deleting Data 
You can delete the entire contents of a cell if the data is no longer needed. Deleting data does not 
remove any formatting applied to the cell. 
 
To delete data: 

1. Select the cell that contains the data you want to delete, and then press the Delete key. 



Moving and Copying Cells 
When editing a worksheet, you may want to duplicate a cell in another location or remove (cut) a 
cell from its original location and place it in a new location. A copied cell can be pasted multiple 
times; a cut cell can be pasted only once. 
 
NOTE: Cut or copied data is stored on the Clipboard, a temporary storage area. You can access it by 
clicking the dialog box launcher  in the Clipboard group on the Home tab of the Ribbon (see Figure 
27). 
 
To move or copy a cell: 

1. Select the cell that you want to move or copy. 
2. On the Home tab, in the Clipboard group, do one of the following: 

 To move the cell, click the Cut button . Or, press Ctrl+X. 

 To copy the cell, click the Copy button . Or, press Ctrl+C. 
3. Select the cell where you want to paste the cut or copied cell. 

4. On the Home tab, in the Clipboard group, click the Paste button . Or, press Ctrl+V. 
NOTE: When you cut or copy cells, a marquee (scrolling dotted line) appears around the cells. 
You can remove the marquee by pressing the Esc key (see Figure 28). 

 

 
Figure 27 – Clipboard Group on the Home Tab 

 
Figure 28 – Cells with Marquee 

Using Paste Special  
The Paste Special command is a very useful editing feature. It allows you to control which 
aspect of the copied cell to paste into the target cell. For example, you can choose to paste only 
the copied cell’s formula, only the result of the formula, only the cell’s formatting, etc. You must 
copy to use the Paste Special command; when you cut, the Paste Special command is not 
available. 
 
To use the Paste Special command: 

1. Select the cell that contains the value, formula, or formatting you want to copy. 

2. On the Home tab, in the Clipboard group, click the Copy button . 
3. Select the cell where you want to paste the value, formula, or formatting. 
4. On the Home tab, in the Clipboard group, click the Paste arrow and select the desired 

option from the menu (see Figure 29). 
NOTE: Pointing to a command on the Paste menu displays its name in a ScreenTip. You can 
access more options by clicking Paste Special at the bottom of the menu. 



 
Figure 29 – Paste Menu 

Clearing Cells 
You can clear a cell to remove its contents, 
formats, or comments. When clearing a cell, 
you must specify whether to remove one, two, 
or all three of these elements from the cell. 
 
To clear a cell: 

1. Select the cell that you want to clear. 
2. On the Home tab, in the Editing group, 

click the Clear button and select the 
desired option from the menu (see 
Figure 30). 

 
Figure 30 – Clear Menu 

Undoing and Redoing Changes 
Whenever you make a mistake, you can easily reverse it with the Undo command. After you 
have undone one or more actions, the Redo command becomes available and allows you to 
restore the undone actions. 
 
To undo an action: 

1. On the Quick Access toolbar, click the Undo button . Or, press Ctrl+Z. 
 
To redo an action: 

1. On the Quick Access toolbar, click the Redo button . Or, press Ctrl+Y. 

Formatting Worksheets 
Excel 2013 includes a number of features that can be used to easily format a worksheet. 
Formatting enhances the appearance of a worksheet and makes it look professional. 



Formatting Cells and Cell Contents 
You can format cells and cell contents by changing the font, font size, font style, and font color, 
as well as adding cell borders and changing the background color of cells. Since formatting is 
attached to the cell and not to the entry, you can format a cell before or after you enter the data. 
The Font group on the Home tab of the Ribbon contains the most commonly used formatting 
commands (see Figure 31). You can also format cells using the Format Cells dialog box which 
can be opened by clicking the dialog box launcher  in the Font group. 

 
Figure 31 – Font Group on the Home Tab 

Changing the Font and Font Size 
A font defines the overall appearance or style of text lettering. Font size controls the height of the 
font. The default font in new Excel 2013 workbooks is Calibri; the default font size is 11 points. 
 
To change the font: 

1. Select the cell that you want to format. 
2. On the Home tab, in the Font group, click the Font arrow and select the desired font 

from the list (see Figure 32). 
 
To change the font size: 

1. Select the cell that you want to format. 
2. On the Home tab, in the Font group, click the Font Size arrow and select the desired font 

size from the list (see Figure 33). If a font size you want is not listed in the Font Size list, 
click in the Font Size box, type the desired number, and then press the Enter key. 

NOTE: You can also change the font size by clicking the Increase Font Size button  or 

Decrease Font Size button  in the Font group on the Home tab of the Ribbon. 
 

 
Figure 32 – Font List 

 
Figure 33 – Font Size List 

 



Changing the Font Color and Fill Color 
You can change the font color of cell contents or the background color of cells to emphasize 
important data or add visual impact to a worksheet. 
 
To change the font color: 

1. Select the cell that you want to format. 
2. On the Home tab, in the Font group, click the Font Color button to apply the most 

recently used color, or click the Font Color arrow and select a different color from the 
color palette (see Figure 34). 

 
To change the fill color: 

1. Select the cell that you want to format. 
2. On the Home tab, in the Font group, click the Fill Color button to apply the most 

recently used color, or click the Fill Color arrow and select a different color from the 
color palette (see Figure 35). 
NOTE: You can remove the fill color from a selected cell by clicking the Fill Color arrow, and 
then clicking No Fill on the palette. 

 

 
Figure 34 – Font Color Palette 

 
Figure 35 – Fill Color Palette 

Applying Font Styles  
You can apply one or more font styles to emphasize important data in a worksheet. Font styles 
are attributes such as bold, italic, and underline. Bolding makes the characters darker. Italicizing 
slants the characters to the right. Underlining adds a line below the cell contents, not the cell 
itself. 
 
To bold or italicize data: 

1. Select the cell that you want to format. 

2. On the Home tab, in the Font group, click the Bold button  or Italic button . 
 
To underline data: 

1. Select the cell that you want to format. 
2. On the Home tab, in the Font group, do one of the following (see Figure 36): 

 To apply a single underline, click the Underline button. 
 To apply a double underline, click the Underline arrow, and then click Double 

Underline on the menu. 



 
Figure 36 – Underline Menu 

NOTE: The Bold, Italic, and Underline buttons are toggles. If you select a cell to which one of these 
formats has been applied, and then click the corresponding button, that format is removed. 

Adding Cell Borders 
You can add borders to any or all sides of a 
single cell or range. Excel 2013 includes 
several predefined border styles that you can 
use. 
 
To add cell borders: 

1. Select the cell to which you want to 
add borders. 

2. On the Home tab, in the Font group, 
click the Borders button to apply the 
most recently used border, or click 
the Borders arrow and select a 
different border from the menu (see 
Figure 37). 
NOTE: You can remove all borders 
from a selected cell by clicking the 
Borders arrow, and then clicking No 
Border on the menu. 

 
Figure 37 – Borders Menu 

Formatting Numbers 
You can apply number formats to cells containing numbers to better reflect the type of data they 
represent. For example, you can display a numeric value as a percentage, currency, date or time, 
etc. The Number group on the Home tab of the Ribbon contains the most commonly used 
commands for formatting numbers (see Figure 38). You can also format numbers using the 
Number tab of the Format Cells dialog box which can be opened by clicking the dialog box 
launcher  in the Number group. 



NOTE: Formatting does not change the actual value stored in a cell. The actual value is used in 
calculations and is displayed in the Formula bar when the cell is selected. 

 
Figure 38 – Number Group on the Home Tab 

 
To format numbers: 

1. Select the cell that you want to format. 
2. On the Home tab, in the Number 

group, do one of the following (see 
Figure 38): 
 Click the Accounting Number 

Format button  to display the 
number with a dollar sign, comma 
separators, and two decimal places. 
NOTE: You can select a different 
currency symbol by clicking the 
Accounting Number Format arrow 
and selecting the desired symbol from 
the menu. 

 Click the Percent Style button  
to convert the number to a 
percentage and display it with a 
percent sign and no decimal places. 

 Click the Comma Style button  
to display the number with comma 
separators and two decimal places. 
NOTE: You can access additional 
number formats by clicking the 
Number Format arrow and selecting 
the desired option from the menu (see 
Figure 39). 

 
Figure 39 – Number Format Menu 

 
To change the number of decimal places: 

1. Select the cell that you want to format. 
2. On the Home tab, in the Number group, do one of the following (see Figure 38): 

 Click the Increase Decimal button  to increase the number of decimal places. 

 Click the Decrease Decimal button  to decrease the number of decimal places. 



Positioning Cell Contents 
You can change the alignment, indentation, and orientation of cell contents, wrap the contents 
within a cell, and merge cells. The Alignment group on the Home tab of the Ribbon contains the 
most commonly used commands for positioning cell contents (see Figure 40). You can also 
position cell contents using the Alignment tab of the Format Cells dialog box which can be 
opened by clicking the dialog box launcher  in the Alignment group. 

 
Figure 40 – Alignment Group on the Home Tab 

Aligning Data 
By default, Excel 2013 aligns numbers to the right and text to the left, and all cells use bottom 
alignment. The Alignment group on the Home tab of the Ribbon includes six alignment buttons 
that can be used to change the horizontal and vertical alignment of cell contents. 

 The Align Left button  aligns the cell contents with the left edge of the cell. 

 The Center button  centers the cell contents horizontally within the cell. 

 The Align Right button  aligns the cell contents with the right edge of the cell. 

 The Top Align button  aligns the cell contents with the top edge of the cell. 

 The Middle Align button  centers the cell contents vertically within the cell. 

 The Bottom Align button  aligns the cell contents with the bottom edge of the cell. 
 
To align data: 

1. Select the cell that contains the data you want to align. 
2. On the Home tab, in the Alignment group, click the desired alignment button. 

Indenting Data 
Indenting moves data away from the edge of the cell. This is often used to indicate a level of less 
importance (such as a subtopic) (see Figure 41). 

 
Figure 41 – Indented Data 

  



To indent data: 
1. Select the cell that contains the data you want to indent. 

2. On the Home tab, in the Alignment group, click the Increase Indent button . Each 
click increments the amount of indentation by one character. 

NOTE: You can decrease the indentation of data by clicking the Decrease Indent button  in 
the Alignment group on the Home tab of the Ribbon. 

Rotating Data 
You can rotate data clockwise, counterclockwise, or vertically within a cell. This is often used to 
label narrow columns or to add visual impact to a worksheet. 
 
To rotate data: 

1. Select the cell that contains the data you want to rotate. 
2. On the Home tab, in the Alignment group, click the Orientation button and select the 

desired option from the menu (see Figure 42). The row height automatically adjusts to fit 
the rotated data (see Figure 43). 

 

 
Figure 42 – Orientation Menu 

 
Figure 43 – Rotated Data 

NOTE: You can restore the data to its default orientation by clicking the Orientation button and 
selecting the currently selected orientation. 

Wrapping Data 
Wrapping displays data on multiple lines within a cell. The number of wrapped lines depends on 
the width of the column and the length of the data. 
 
To wrap data: 

1. Select the cell that contains the data you want to wrap. 

2. On the Home tab, in the Alignment group, click the Wrap Text button . The row 
height automatically adjusts to fit the wrapped data (see Figure 44). 
NOTE: You can restore the data to its original format by clicking the Wrap Text button again. 

 
Figure 44 – Wrapped Data 



Merging Cells  
Merging combines two or more adjacent cells into one larger cell. This is a great way to create 
labels that span several columns. 
 
NOTE: If the cells you intend to merge have data in more than one cell, only the data in the upper-left cell 
remains after you merge the cells. 
 
To merge cells: 

1. Select the cells that you want to merge. 
2. On the Home tab, in the Alignment group, click the Merge & Center button to merge 

the selected cells into one cell and center the data, or click the Merge & Center arrow 
and select one of the following options (see Figure 45): 
 Merge Across: Merges each row of the selected cells into a larger cell. 
 Merge Cells: Merges the selected cells into one cell. 

 
Figure 45 – Merge & Center Menu 

NOTE: You can split a merged cell by clicking the Merge & Center arrow, and then clicking 
Unmerge Cells on the menu. 

Copying Cell Formatting 
You can copy the formatting of a specific cell and apply it to other cells in the worksheet. This 
can save you time and effort when multiple formats have been applied to a cell and you want to 
format additional cells with all the same formats. 
 
To copy cell formatting: 

1. Select the cell that has the formatting you want to copy. 

2. On the Home tab, in the Clipboard group, click the Format Painter button . The 
mouse pointer changes to a plus sign with a paintbrush . 

3. Select the cell to which you want to apply the copied formatting. 
NOTE: If you want to apply the copied formatting to more than area, double-click the Format 
Painter button instead of single-clicking it. This keeps the Format Painter active until you press 
the Esc key. 

Applying Cell Styles 
A cell style is a set of formatting characteristics (such as font, font size, font color, cell borders, 
and fill color) that you can use to quickly format the cells in a worksheet. In addition to saving 
you time, cell styles can help you keep formatting consistent throughout a worksheet. Excel 2013 
includes several predefined styles that can be used to format headings, numbers, notes, etc. 
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CONDITIONAL FORMATTING 
 
Excel can be used to highlight data that meets conditions that you specify. To 

highlight formula results or other cell values that you want to monitor, you can 

identify the cells by applying ‘Conditional Formats’.  

 

Setting A Conditional Format 

 

For instance, in an Orders data set, Excel can apply red shading to the cell, if the 

‘Total Price’ is greater than £1,000 or blue shading if the ‘Total Price’ is less than 

£1,000.  To apply conditional formats to cells ; 

 

1 Select the cells you want to format. In this example, select the ‘Total 

Order’ cells only. 

2 Select ‘Conditional Formatting’ from the ‘Home’ tab. 

 

 

 

3 Select ‘Highlight Cell Rules’. 

4 Then select an appropriate option e.g. ‘Greater than… 
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5 Enter the amount in the first dialogue box & then select the drop down 

option in the second dialogue box, to set the appropriate formatting 

options. Use ‘Custom Format’ if you want to set your own formatting 

options. 

6 Select the font style, font colour, underlining, borders, shading, or 

patterns you want to apply. 

7 To add another condition, repeat the steps above. 

8 To review the conditional formats applied to the cells, use ‘Conditional 

Formatting….Manage Rules’ from the ‘Home’ tab. 

9 Here you can create new rules or modify / delete existing rules. 
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Using Formulae As Conditions 
 

In the previous example, the cell colour in a single column (Total Order) was 

changed. In order to apply the cell colour all the way across a row, then a formula 

could be used. 

 

1 Select the cells you want to format (the whole data set). 

2 Select ‘Conditional Formatting….New Rule’ from the ‘Home’ tab. 

3 Select ‘Use a formula to determine which cells to format’. 

4 Enter a suitable formula & format for the cells & click ‘OK’. 

 

 
 

 
5 In this example, the formula would be  =$I2 > 1000. 
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Style Sets 
 

Data Bars, Colour Scales & Icon Sets can also be used to format cells. In the 

example below, ‘Total Prices’ can be marked with ‘Traffic Lights’ to indicate 

whether the Total is less than £250, between £250 - £1,000 or over £1,000. 
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Identifying All Cells With Conditional Formatting 

 

If your worksheet has one or more cells with a conditional format, you can quickly 

locate them so that you can change or delete the conditional formats. You can use 

the ‘Go To Special’ command, to either find only cells with a specific conditional 

format or find all cells with conditional formats. 

 

1 Click any cell without a conditional format. 

2 In the ‘Home’ tab, click the drop down arrow under ‘Find & Select’. 

3 Select ‘Conditional Formatting’. 

 

 

 

4 Any Conditionally formatted cells will be selected. 
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Editing / Deleting Conditions 
 

To delete a condition ; 

 

1 Select your ‘Conditionally Formatted’ cells. 

2 Select ‘Conditional Formatting….Manage Rules’ from the ‘Home’ tab. 

 

 
 

 
3 Select the format to delete & click ‘Delete Rule’. 

4 Edit a Conditional Format, in the same manner, by clicking ‘Edit Rule’. 
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SORTING AND FILTERING DATA 
 
 
Sorting A List By A Single Column 

 
 

To sort data in ascending / descending order based on values in a single column ; 

 

1 Click a cell in the column you want to ‘sort’.  

 

DO NOT HIGHLIGHT MULTIPLE CELLS 

 

2 Click the ‘Sort Ascending’ or ‘Sort Descending’ icon on the ‘Data’ tab. 

 

Sorting A List By Multiple Columns 
 

If you require a more complicated sorting procedure i.e. you want to sort by more 

than one column, you will need the ‘Sort’ icon on the ‘Data’ tab. When you sort by 

more than one column, the rows with duplicate items in the first column are 

sorted according to the second column you specify. To do this ; 

 

1 Click a cell in the column you want to ‘sort’.  

2 Click the ‘Sort’ icon on the ‘Data’ tab. 

 

 

 
 

3 Select the 1st sort options you want e.g. above, list is sorted by ‘Dept’. 

4 Click ‘Add Level’. 
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5 Repeat the selection process, for the 2nd level.  

 

The list above will be sorted by ‘Dept’ first, then within each department, by ‘Full 

Name’. 

 

 

 

6  Potentially, extra levels may be required, until you obtain the ‘Sort’ order 

you require. 
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Sorting A List By Colour 
 

If you have manually or conditionally formatted a range of cells, by cell colour or 

font colour, you can also sort by these colours. You can also sort by an icon set 

created through a conditional format. 

 

 

 

In the above example, a Conditional Format has been applied to highlight 

‘Delivery Bands’ ; 

 

1 - 10 Days   Green 

11 - 20 Days   Amber 

Over 20 Days  Red 

 

Using the ‘Sort’ option, you can sort by colour ; 

 

1 Click a cell in the data you want to ‘sort’.  

2 Click the ‘Sort’ icon on the ‘Data’ tab. 
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3 Select the 1st sort option, e.g. ‘Delivery Band’, then in the ‘Sort On’ 

column, select the ‘Cell Colour’ option. 

4 In the ‘Order’ column, select the colour & whether it is to be sorted ‘On 

Top’ or ‘On Bottom’. 

5 Then click ‘Add Level’ & repeat the process. 

 

 

 

6 Make sure that you select the same column in the ‘Then by’ box and that 

you make the same ‘On Top’ selection for your next colour. 

7 Keep repeating for each additional cell colour, that you want included in 

the sort. 
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The above settings, will sort the list with ‘Green’ at the top of the list, followed by 

‘Amber’ then ‘Red’. 

 

 

Filter A List 

 
 
By filtering a list, you can display just the rows that meet the criteria you specify. 

For example, in a list of names and addresses, you can see only the names of 

people who live in Newcastle. There are two ways to filter a list in Microsoft Excel 

i) using the ‘AutoFilter’ command or ii) the ‘Advanced Filter’ command, both on 

the ‘Data’ tab.  

 

The ‘AutoFilter’ command displays arrows next to the column labels in a list, so 

you can select the item you want to display. Use the ‘AutoFilter’ command to 

quickly filter rows using criteria in a single column. 

 

The ‘Advanced Filter’ command, filters your list, as ‘AutoFilter’ does, but it does 

not display arrows in column labels for criteria selection. Instead, you type criteria 

in a criteria range on your worksheet.  
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Filter A List Using AutoFilter 
 

For this procedure to work, your list must have ‘column labels’. 

 

1 Select a cell in the list you want to filter. 

2 Select ‘Filter’ from the ‘Data’ tab. 

3 Click the arrow in the column, that contains the data you want to filter. 

 

 
 
 

4 Remove the check mark from ‘Select All’. 

5 Select the check box for the entry you want to filter & then click ‘OK’. 

6 You can select multiple check boxes to filter on two or more items. 

7 Alternatively, type your criteria in the ‘Search’ box. 

8 You can create ‘Custom’ filters by using ‘Text Filters….Custom Filter’. 
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9 If you have ‘Date’ data, then a particular set of filters are available, by 

using ‘Date Filters……’ 

 

 

 

10 Similarly, numeric data has it’s own set of filters. 

11 You can also filter by ‘Colour’. 

 

 

 

You can also copy & paste a ‘Filtered’ list to another part of the  

 

worksheet or to another worksheet altogether. 
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RE-ORGANISING DOWNLOADED DATA 

 
When data is downloaded (exported) from other database applications, there can 

be several problems with the data ; 

 
 Data is contained within one column. 

 Data contains unwanted spaces (normally at the front of the data). 

 Data contains non-printing characters. 

 
The spreadsheet below, demonstrates all of these problems. 

 

 

 
 

 
Converting Text To Columns – Parsing Data 

 
The data above is separated by a ‘,’ character & contains 5 parts of the address in 

the same column. This data therefore needs to be spilt up (parsed) into 5 separate 

columns. 

 

1 Ensure you have sufficient (new) blank columns, to the right of the column 

containing data. In the above example, 4 new columns are required. 
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2 Select all of the data in the column & then in the ‘Data’ tab, select ‘Text To 

Columns’. 

 

 
 

 
3 If the data has ‘separators’ e.g. ‘ ,  ’, select ‘Delimited’, then click ‘Next’. 

 

 

 
 
4 Either select the ‘Delimiter’, or type it in the ‘Other’ box. 

5 Click ‘Next’ 
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6 Each column can be formatted before splitting the data. 

7 Click ‘Finish’.  

8 Assuming you have entered the required number of empty columns (as 

described previously), click ‘OK’. 

 

 

 
 

 
9 If you have not entered new columns, you will have to click ‘Cancel’ at this 

point, insert the blank columns & then go through the procedure again. 

10 The data will then be separated into the required number of columns & in 

this example, the address will be split into the appropriate parts. 
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Removing Spaces 

 
Use the TRIM function to remove all spaces from text, except for single spaces 

between words.  

=TRIM(S2) 

 
The formula would need to be entered in a new column & then copied & pasted 

(use ‘Paste Special’) to paste the ‘Values’ over the existing data. 

  
Removing Non-Printing Characters 

 
Occasionally, data which has been exported from another application, may contain 

non-printing characters. 

 

Use the CLEAN function to remove these characters from text.  

 
=CLEAN(S2) 

 
These 2 functions could be combined, in to a single formula. 

 

=TRIM(CLEAN(S2)) 
 

 

In order that both operations are performed in a single formula, without the need 

to enter 2 separate formulae. 
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CALCULATIONS USING FORMULAE 
 
Excel can perform calculations on your data. This can be done by using ‘formulae’ 

within your spreadsheet. All formulae within Excel have the equals sign (=) as the 

first character.  

 

All formulae within Excel have the equals sign (=) as the first character. 

 
All standard arithmetic operators can be used ; 

 

Operation Excel Key Example 

Addition + (plus sign) =A1+B3 

Subtraction - (minus sign) =A1-B3 

Multiplication * (star or asterisk) =A1*B3 

Division / (forward slash) = A1/B3 

Exponential ^ (caret) =A1^2 (equiv to A1 squared) 

Brackets ( ) (open / close brackets) =(A1+B3)/C4 

 

 
The order that a calculation is performed is important to remember. Excel follows 

the standard mathematical rules i.e. the following order is adopted ; 

 

1 Anything in brackets is done first,….. then   B 

2 Orders e.g. squared, square root etc.    O 

3 Division.        D 

4 Multiplication.       M 

5 Addition.        A 

6 Subtraction.       S 

 

Thus, the following formulae ; 

 

=  5+7*3 Produces the answer 26. 

=  (5+7)*3 Produces the answer 36. 
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Creating A Simple Formula 

 

 
To create your own formula ; 

 
1 Start with an equals sign =. 

2 Enter the formula e.g. =54 / 7. 

3 Press the ‘green tick’ on the toolbar or press the ‘ENTER’ key. 

4 The cell will display the result of the formula. 

5 The actual formula itself, will be visible in the ‘Formula Bar’. 

 
Formulae Involving Cell References 

 

 
Excel has the ability to perform calculations based on the content of other cells in a 

spreadsheet (as in the example below).  

 
1 Make the active cell, the cell where you want to put your formula. 

2 Start with an equals sign =. 

3 As you are using cell references, click in the first cell you require in your 

formula (D2, in the example below). 

 

 

 
 

 

 
4 Enter the required arithmetic operator e.g. * 

5 Complete the remaining formula 

6 Press the ‘green tick’ on the toolbar or press the ‘ENTER’ key. 

7 The cell will display the result of the formula. 

8 The actual formula itself, will be visible in the ‘Formula Bar’. 
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Addition Of Columns Or Rows 
 

To add a whole group of cells together, a formula such as ‘=A1+A2+A3….etc.’ could 

be used, however, this would be rather tedious if there were hundreds of cells to add.  

 

Using the ‘AutoSum’ button          on the ‘Formulas’ or ‘Home’ tab, is 

the quickest method. To use the ‘AutoSum’ button ; 

 

1 Move to the cell where the answer will be displayed. 

2 Press the ‘AutoSum’ button 

3 Excel makes a ‘best guess’ at which cells you are going to add up and 

displays them in the formula bar. It does this by looking at the cells directly 

above the active cell or if no data are present, to the left of the active cell. 

4 If it has not chosen the correct ‘cell range’, select it using the mouse. 

5 Press ‘Enter’. 

  
 
Copying Formulae – Relative & Absolute References 

 

Formula can be copied into other cells and can be made either a ; 

 

1 Relative reference, or 

2 Absolute reference 

 

A relative reference e.g. F5, should be used if you always want to refer to cells 

relative to the cell containing the formula, even if you copy the formula. When you 

copy a formula, Excel automatically adjusts itself to look at the correct cells.  

 

If you have a formula ; 

 
=B6 * 7 and copy this down a column, the formulae below it, will become  

=B7 * 7 

=B8 * 7 

=B9 * 7 

=B10*7………..and so on. 
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If however, you want to refer to the same cell regardless of where the formula is on 

the worksheet, use an absolute reference. 

 

A ‘$’ sign should be placed before the column letter or row number (whichever is 

appropriate), in order to ‘freeze’ the cell reference when it is copied. 

 

 

 

 

 

If, in the above example, in Column G, cell F2 is multiplied by the contents of L1 

and you want all the subsequent cells, to be multiplied by L1, then you should use 

the formula =F2*L$1. In this example, L1 has become an absolute reference and 

when you copy this formula, it will always retain L1, although changing the cell 

numbers of column F.  

 

=F2 * L$1 

=F3 * L$1 

=F4 * L$1 

=F5 * L$1 

=F6 * L$1…………and so on. 
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Formulae Using Functions 
 

In addition to simple mathematical operators e.g. multiplication, subtraction etc., 

Excel has a variety of ‘Functions’, these are available via the ‘Insert Function’ icon, 

on the ‘Formulas’ tab or the fx button, to the left of the ‘Formula Bar’. 

 

 
   

 
      
 

The use of several of the most commonly used functions e.g. SUM, AVERAGE, 

COUNT, were discussed in the ‘Introduction’ course. 

 

Due to the large number of functions available, it is beyond the scope of this guide 

to cover all of these functions, however, the following examples show how to use 

some of the more commonly used functions. You can search for a function by 

typing the function name, in the ‘Search for a function’ box & clicking the ‘GO’ 

button. 
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Using IF Statements 
 

You can use the IF statement to determine if a particular ‘criteria’ is true or not, 

and then produce a response depending on the outcome. For example, if you had 

a ‘Production’ worksheet, detailing daily production figures & targets, you could 

use an IF function, to check whether production targets, have been achieved. 

 

 

 
 
 

The example above, uses an IF function (column ‘E’) to check production figures. 

 

If you do not want both the ‘True’ & ‘False’ text to appear, you must use a blank 

set of speech marks  “” in the box, otherwise FALSE will be displayed in the cell. 
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Looking Up Values In A Table 
 

You can look up the contents of various cells within a data set. For example, if an 

item has a particular code, you simply enter the code number and the name of the 

item, will be displayed. 

 

 
Using VLOOKUP 
 

This function looks down a vertical column of data until an appropriate value is 

found. In the example below, an orders sheet is set up, so that when the ‘Item 

No. is present in column ‘B’, it ‘looks up’ the ‘Description’, ‘Item Type’ & 

‘Company’ & enters these into columns ‘C’, ‘D’ & ‘E’ respectively. 

 

 

 
 
 
 

The ‘Description’, ‘Item Type’ & ‘Company’ are stored on a separate sheet ‘Item 

Nos’ (above).  
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To work through the VLOOKUP function, the worksheet that holds the reference 

data i.e. the ‘Item Nos’ sheet, must have the reference column i.e. ‘Item No.’ as 

the first column, on the left of the main data (see above). 

 

You would enter the following parameters, in the VLOOKUP function ; 
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You will thus end up with the following formula, in your cell. 

 
 

=VLOOKUP(B2, 'Item Nos'!A:E,2,FALSE) 

 
 

Where :  
 
 

Lookup_value = Cell where Item No. is entered (B2) 

Table_array = Area where Item No & Description are stored (Item Nos'!A:E) 

Col_index_num = Second column, along to the right of column ‘A’ (2) 

Range_lookup  = Ensures an exact match is found (False) 
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Conditional Sums 
 

To ‘Sum’ values in a list (that meet specific conditions) use the ‘SUMIF’ function. 

 

 
 

 
The formula below, calculates the total cost of all courses, attended by Finance 

employees. 

 

 
 

 
=SUMIF(D:D,N2,L:L) 

Where ; 

 

Range Is the range of cells you want evaluated (D:D) 

Criteria  Is the criteria, in the form of a cell reference that defines which 

cells will be added. E.g. in the above example, the Total Cost is 

calculated, using a cell reference of ‘N2’, for the criteria. 

Sum_range Are the actual cells to sum. The cells in ‘sum_range’ are summed 

only if their corresponding cells in ‘range’, match the criteria (L:L).  
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There is a new function in Excel 2010 (SUMIFS), which allows the addition of cells 

in a range that meet multiple criteria. 

 

 
 

 

For example, in the above data set, you could calculate the total cost (Column L) 

of all Excel courses (Column H), attended by Finance employees (Column D). 

 

The expression would look like ; 
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Extracting Data from the Left or Right of a Cell 

 
If data in a cell, needs to be ‘split up’ or certain characters extracted from either 

end of a data set, then the ‘Left’ or ‘Right’ function can be used. For example, if an 

employees number was in the format 0045M, where the last character denoted 

the gender of the person and the data was stored in Column A, then the final 

character could be extracted using the formula ; 

 

 

 
 

 

 
=RIGHT(A2,1) 

 

Where ; 

 

Text = cell containing data e.g. Clock No. (A2) 

Num_chars =  no. of charatcers from the right of this cell, to extract (1) 
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Combining Cell Content 

 
It is possible to combine or join together information, from different columns on a 

spreadsheet, using the ‘Concatenate’ function. E.g. if the employees ‘Surname’ & 

‘Initial’, are stored in separate columns in a worksheet.  

 

 
 

 
=CONCATENATE(E2," , ",D2) 

 

 

 
 

Where ; 

 

Text 1, 2, 3 etc = Cells to be combined (E2, D2) 

“ ”   = Use “ ” to indicate space between cells. 
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PIVOT TABLE 
 
What Is A Pivot Table ? 
 

A Pivot Table is an interactive worksheet table that summarises and analyses data 

from an existing list. You decide which of the fields (in the list) are to be arranged 

in rows and columns. You can re-arrange the table very easily, in effect ‘twisting’ 

the data around - hence the name Pivot Table. 

 

Most Excel spreadsheets are generally of the same format i.e. they contain a 

series of fields (column headings) containing data in rows. 

 

The following example shows a spreadsheet that contains information on the 

training carried out within a company, from 2007-2013. It lists the delegate 

details, training provider, course and cost of training. It contains a lot of 

information & it is very difficult to get an overall ‘summarised’ view. This is where 

the ‘power’ of a Pivot Table lies. They effectively display the result of a ‘database 

analysis’. 
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The Pivot Table Wizard 
 

You create Pivot Tables by using the Pivot Table Wizard. Although this only takes a 

few moments, it is worth spending some time to decide how you want to 

summarise your data. To create a Pivot Table ; 

 

1 Select a cell in your data & select ‘Pivot Table’ from the ‘Insert’ tab. 

 

 

 
 

 
 

2 The range of your data should be entered automatically, modify, if not 

correct. 

3 Select whether the pivot table is to be placed on a new worksheet or 

within your existing worksheet. 

4 Click ‘OK’. 

 

 



Nomas Training & Consultancy Ltd 

 

 

                             
 

Excel 2010 – Analysing Data Using Formulae & Pivot Tables Page 36 

 
 
 

5 You need to drag (or tick) the ‘Fields’ from the right hand side, onto the 

appropriate lower part of the table (areas marked ‘Drag Fields Between 

Areas Below’) & into the ‘Row’, ‘Column’, ‘Values’ areas. 

 
 

VALUES 
This field contains the data that you want to 
summarise (often a numeric field). 

ROW 
This is the field that you want to appear as rows 

with labels down the side of the table. 

COLUMN 
This is the field that you want to appear as columns 

with labels across the top of the table. 

REPORT FILTER See later. 
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6 The Pivot Table is created (next page). 

 

 

 
 

 

 
7 You can have several field headings, in any one of these areas. Example 

below has ‘Dept’, ‘Group’ & ‘Course’, in the ‘Row’ area. 
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Creating Pivot Filters 
 

As it is not possible to read text in three-dimensions, all the fields that you want 

to see in a pivot Table are ‘squashed’ into the row or column positions. 

 

However, it is possible to create a third dimension to provide added flexibility to 

your data. This is done by creating a Pivot Filter. 

 

To create a Pivot Filter ; 

 

1 Start the Pivot Table Wizard. 

2 Complete steps as described previously. 

3 In Step 5, move the field that you want to filter to the ‘Report Filter’ area. 

4 Continue as described previously. 

 

 

 
 

 
5 In the above example the ‘Course’ field has been added to the ‘Filter field, 

so that the training can be filtered by ‘Course’. 
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Changing Date Grouping 

 
If a ‘Date’ field is used in a Pivot Table, it does not automatically ‘group’ data by 

month or year. Therefore, you need to set the grouping level, by right clicking on 

the ‘Date’ area & selecting ‘Group’.  

 

 

   

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can then set the level required, e.g. ‘Months’, ‘Quarters’ etc. 

 
 

Adding Sub Totals 

 

 
If ‘Sub-Totals’ are not automatically displayed, it is possible to add them 

manually, in the example (over) the ‘Annual’ sub-totals do not appear 

automatically. 
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To add them ; 

 

1 Right click onto the relevant ‘Field’ heading – ‘Years’ in this example & 

select ‘Field Settings’. 

 

 

 

2 Select ‘Subtotals….Automatic’ 

3 Click ‘OK’. 
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Re-Designing A Pivot Table 
 

There are 2 Custom Tabs, that are available when using a Pivot Table. 

 

Pivot Table Tools – Options 
 

 

 

 

Pivot Table Tools – Design 
 

 
 

Commonly, this tab is used for selecting a particular colour scheme, ‘PivotTable 

Style’, for your pivot table. 

 
Drilling Down Into The Data In A Pivot Table 
 

To see the ‘underlying’ data, in the Pivot Table, simply double click in the Pivot 

Table data. For example, to see the ‘Employees Trained’ in HR, by the ‘Nomas’ 

training provider, double click in the appropriate cell e.g. 480 (below) & the data 

will be copied into a new sheet. 
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Slicers 

 

Slicers are easy-to-use filtering components, that contain a set of buttons that 

enable you to quickly filter the data in a PivotTable, without the need to open 

drop-down lists to find the items that you want to filter. 

 

When you use a regular PivotTable filter to filter on multiple items, the filter 

indicates only that multiple items are filtered, and you have to open a drop-down 

list to find the filtering details. However, a slicer clearly labels the filter that is 

applied and provides details so that you can easily understand the data that is 

displayed in the filtered PivotTable report. 

 

 

Create A Slicer In An Existing Pivot Table 
 

1 Click anywhere in the PivotTable, for which you want to create a slicer. 

2 On the ‘Options’ tab, click ‘Insert Slicer’. 
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3 In the ‘Insert Slicers’ dialog box, select the check box of the PivotTable 

fields for which you want to create a slicer. 

4 Click ‘OK’. 

5 A ‘slicer’ is displayed for every field that you selected. 

6 In each slicer, click the items on which you want to filter. 

 

 

 

 

 

7 To select more than one item, hold down CTRL, and then click the items on 

which you want to filter. 

8 Click an item in the ‘Slicer’, to see the Pivot Table data. 

 

Format A Slicer 

 
1 Click the slicer that you want to format. 

2 This displays the ‘Slicer Tools’, adding an ‘Options’ tab. 

3 On the ‘Options’ tab, click the style that you want. 
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Delete A Slicer 
 

Do one of the following ; 

 

1 Click the slicer, and then press ‘DELETE’. 

2 Right-click the slicer, and then click ‘Remove <Name of slicer>’. 

 

Updating A Pivot Table 

 
 

The Pivot Table does not change when you update your data in the source list. You 

can update your Pivot Table, by ; 

 

1 Selecting any cell within the Pivot Table. 

2 Click the ‘Refresh’ icon, in the ‘Pivot Table Tools’ tab. 

 
 

Creating A Chart From A Pivot Table 
 

You can create a chart linked to a pivot Table. 

 

1 Select a cell within the Pivot Table data - avoid selecting any of the field 

tabs as this will move them within the table. 

2 Click the ‘Pivot Chart’ icon, in the ‘Pivot Table Tools’ tab. 

3 Select the type of chart you require & click ‘OK’. 

4 The chart will be created on your existing sheet. 
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Re-Organising The Pivot Table 

 
 
Adding Columns And Rows 

 
To enhance the amount of detail available in your Pivot Table, you can add more 

fields. Adding row and column fields expands the table and widens the view. In 

contrast to adding a Filter, which narrows the scope. 

 

To add a column or row ; 

 

1 Select a cell in your Pivot Table. 

2 Move the ‘Field’ that you want to move into the appropriate area (ROW, 

COLUMN etc). 

 

 
 

 
Removing Columns And Rows 

 
 

1 To remove a row or column, drag it back onto the top half of the ‘Field 

List’. 



Nomas Training & Consultancy Ltd 
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Changing The Summary Functions 
 

Excel summarises data by summing numeric values (if the data fields contain text, 

the Pivot Table displays counts of the values). You can change the summary 

function or calculation type ; 

 

1 Select a heading in the ‘Values’ area of the ‘Field List’. 

 

 

 

2 Click the drop down arrow & select ‘Value Field Settings’. 

 

 
 

 
3 In the ‘Summarise by’ list, select the desired summary function. 



Nomas Training & Consultancy Ltd 
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Hiding / Displaying Sub & Grand Totals 

 
 
The ‘Sub Totals’ & ‘Grand Totals’ can be controlled from the ‘Design’ tab. 

 

Sub – Totals 
 

 
 

 
Grand Totals 
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RELATIVE & ABSOLUTE ADDRESSING 

There are different sorts of cell references.  These are: 

• Relative 
• Absolute 
• Mixed 

A relative reference will change column and row numbers as it is copied to other cells.  
Think of it as an original instruction being to go in a certain direction e.g. 2 rows up and 2 
columns across from your current position.  When this instruction is copied elsewhere, it 
will still refer to 2 rows up and 2 columns across from your new current position. 

An absolute reference is one that does not change.  If you refer to a cell in a certain row 
and column and then copy that reference elsewhere, it will still refer to exactly the same 
cell or range. 

A mixed reference is one that is half relative and half absolute. 

An absolute address is defined with the use of the “$” symbol.  This can be typed in at the 
time of creating the formula, or by editing the cell afterwards.  

Examples of relative and absolute addressing: 

Relative A4 A4:B5 

Absolute $A$4 $A$4:$B$5 

Mixed $A4 or A$4 $A4:B$5 

 

The “$” sign can be hand typed or inserted by pressing the keyboard shortcut F4.  
As you press F4 the cell address will cycle between the four variations of an 
address – for example A4 would cycle between: 

   A4 
   $A4 
   A$4 
   $A$4 



 

S:\Administrative\Information Technology\Customer Services Management\Education and Training Team\Current Training 
Modules\Advanced Excel\Advanced Excel formulas and functions.doc 

Page 7 

 

NAMING CELLS AND RANGES 

Cells and ranges can be given a name so that when you need to refer to that cell or range 
of cells, you can refer to its name rather than an address. 

Example In the screenshot below, traditional cell addresses have been used for 
working out January’s profit or loss. 

 

In the screenshot below, row 6 has been given the name Total_Income and Row 15 the 
name Total_Expenditure.  When the formula for February was done, the syntax was 
Total_Income – Total_Expenditure.   Using names may make it easier to understand 
what the formula is doing – it might make more sense to some, than saying B6 – B13. 
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There are a couple of ways to create a range name.  They both require that you select the 
cell or range or before creating the name. 

Method 1:  INSERT, NAME, DEFINE option (or CTRL + F3) 

1. Go to the INSERT, NAME, DEFINE dialog box (or press the keyboard shortcut 
CTRL + F3).  The DEFINE NAME dialog box will appear; 

2. Give the cell or range you selected a name (quite often, as in the example 
screenshot below, the name suggested by Excel is more than adequate); 

3. Click on ADD, then click on CLOSE. 

NOTES: • Range names must be one word – if you require 2 words, join them with an 
underscore as in the example below.   

 • The names can be a combination of numbers and letters, but must not start 
with a number. 

 • The default is to show the address as being ABSOLUTE.  By clicking in the 
REFERS TO text box, this can be edited to what is required. 

 

 • As a default, names are workbook level i.e. the name you create is available 
throughout the whole workbook.   

 • If the worksheet has been named with a name that includes spaces, the 
worksheet name will have to be enclosed in single quotation marks.   

Method 2:  Using the NAME box 

1. Highlight the cell or range(s) that is going to be named; 

2. Click in the NAME box (see the following screenshot).  The contents of the name 
box will be highlighted; 

3. Type the RANGE NAME you want and ENTER to accept the name. 
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Applying a Range Name in a Formula 

To use the RANGE NAME in a formula either: 

1. Type the name – make sure you use the correct spelling or else the function will not 
recognise the name; or 

2. When you are in the part of the formula that requires the RANGE NAME, press the 
keyboard shortcut F3.  This brings up the PASTE NAME dialog box.  Select the 
name and click on OK. 

 

 

 When working with many names, you can have a list of these names and 
the cells or ranges they refer to placed in your workbook by using the 
PASTE LIST option (located in the PASTE NAME dialog box - see 
screenshot above).  Make sure you are in an empty cell and have 2 columns 
free and as many rows as there are names before using this option. 

 The first column will list the RANGE NAMES, the second column shows the 
range address that the range name refers to. 
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USING NAMES FOR CONSTANTS OR FORMULAS 

In addition to using Names to name cells or ranges, you can also name constants or 
formulas, these constants or formulas don’t have to appear in a cell.  This is a good way of 
storing a constant or a formula that may have to be used several times. 

An example worksheet called NAMING FORMULAS has been created in the Advanced 
Excel Exercises workbook, should you wish to try out this feature. 

Naming a constant 

Imagine having to work out someone’s holiday leave loading.  You might have the leave 
loading in a cell (H6 in the example below), so that you can use this value in a formula.  By 
having the value in a separate cell, if the leave loading rate ever changes you would only 
have to change the value in H6 and all formulas referring to this cell would update. 

The formula in this case is =(D5/52)*4*$H$6, i.e. the salary divided by 52 weeks, 
multiplied by 4 weeks and then multiplied by 17.5%. 

 

By using a name in the formula rather than a cell address, you save space in the 
spreadsheet and make the formula more readable i.e. what is easier to read? 

=(D5/52)*4*$H$6; or 
=(D5/52)*4*loading 

To give the leave loading of 17.5% (which is a constant) a name you: 

1. Open the DEFINE NAME dialog box (INSERT, NAME, DEFINE or CTRL + F3). 

2. Give the constant a name i.e. Loading 

3. In the REFERS TO: section enter the amount of the constant (without an “=” sign, 
Excel will add this in for you). 

4. Click on ADD, then CLOSE to close the DEFINE NAME dialog box. 
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5. When creating the formula, use F3 when it is time to refer to the loading, select the 
name Loading and ENTER to accept the setting (or click on OK), then continue 
creating the formula in the normal way.  (As mentioned previously, you can type the 
name of the range but if spelled incorrectly, this formula will not work). 

 

Naming a Formula 

Take the above example one step further - instead of referring to the leave loading to do 
the last bit of multiplying, why not put the whole part of working out the leave loading into 
one name? i.e. Take the cell containing the salary and multiply it by loading.  The formula 
would look like:  =Loading 

To name a formula you: 

1. Open the DEFINE NAME dialog box (INSERT, NAME, DEFINE or CTRL + F3). 

2. Give the formula a name i.e. Loading 

3. In the REFERS TO: section  

 • type an “=” sign to start off the formula 
 • open a left bracket “(“ 
 • in the spreadsheet click on the cell containing the salary (i.e. D5 in the 

example used previously) 
 • NOTE: this cell address is ABSOLUTE (i.e. it says $D$5).  Use the F4 key to 

make the reference relative i.e. D5.  If you don’t, when you copy the formula to 
all the other staff members, each formula will refer to Fred Smith’s salary. 

• type /52)*4*17.5%  
 • the formula should read =('NAMING FORMULAS'!D5/52)*4*17.5% (if 

you used the exercise provided).  If you used a new sheet it will look 
something like =(Sheet1!D5/52)*4*17.5% 

4. Click on ADD, then CLOSE to close the DEFINE NAME dialog box. 

5. When creating the formula make sure you are in appropriate cell, then either: 

 • use F3 to select the name ‘LOADING’ and ENTER to accept the setting (or 
click on OK), ENTER again or click on the green  to finish the formula; or 

 • Type =loading then ENTER or click on the green  to accept. 
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REFERENCING OTHER WORKSHEETS AND WORKBOOKS 

Referencing Other Worksheets 

The easiest and most accurate way to reference a cell or range in another worksheet is to 
use the point method (i.e. physically go to the worksheet and select the cell or range whilst 
you are creating your formula).  Excel then refers to that worksheet in the correct syntax 
which is the sheet name, followed by an exclamation mark (!), followed by the cell or 
range, e.g.  Sheet1!A1:B4.  

• If the worksheet has been renamed, the name is used instead of the sheet and 
number, e.g. for a sheet that is named Budget it would be Budget!A1:B4. 

• If the sheet name includes spaces, the sheet name must be enclosed within single 
quotation marks, e.g. a sheet that is named Budget 2004 would be  
’Budget 2004’!A1:B4. 

The following steps show how to use the pointing method to make a reference to another 
worksheet in a formula.  An exercise has been set up in the workbook - Referencing other 
workbooks and sheets.xls: 

1. Click in B7 on the sheet called “Budget”.  An amount from the “Recurring 
Expenses” sheet is to go here. 

2. Type an equal sign (=).  This tells Excel you are starting a function, at the same 
time it ‘anchors’ you to this cell so that you can go to other worksheets or 
workbooks and be able to point at cell references in those worksheets/workbooks. 

3. Click on the Recurring Expenses sheet tab and click on B7, which is the total of 
recurring expenses.   

4. Press ENTER on the keyboard to finish the function off or if you prefer, click on the 
green   next to the formula bar.   

The amount of the total recurring expenses is now placed in Cell B7 on the Budget sheet.   
Notice the formula in B7 reads          ='Recurring Expenses'!B7 

5. Click in B8 on the sheet called “Budget”.  A small formula that works out 5% of 
salary (located on the Recurring Expenses worksheet) is to go here. 

6. Type an equal sign (=) and then click on cell B11 on the Recurring Expenses sheet. 

7. Now type an asterisk (*) to multiply the total income by 5%. 

8. Type .05 (i.e. 5/100) and press ENTER on the keyboard to click on the green  to 
finish the function (typing 5% will also work) 

Your function should read  ='Recurring Expenses'!B11*0.05 or  
     ='Recurring Expenses'!B11*5% 

Keep this workbook open for the “Referencing Other Workbooks” example. 
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Referencing Other Workbooks 

The easiest way to reference another workbook is to have that workbook open while you 
are making reference to it.  If you do not have the workbook open you will have to type in 
the full name and path of the workbook when referring to it, which can be quite tedious.  
The syntax for referring to a worksheet is the name of the worksheet enclosed in square 
brackets, followed by the sheet name, an exclamation mark, then cell addresses or 
ranges.  e.g.    [worksheet.xls]Sheet1!Cell reference 

If the workbook name includes spaces, the workbook AND sheet name must be enclosed 
within single quotation marks, e.g. to refer to a cell in a workbook called “Yearly 
Expenses.xls” you would type:    '[Yearly Expenses.xls]Sheet1'!A1 

If the workbook you are referencing is closed at the time of building the function, you must 
include the full path name of the workbook.  e.g.  

'd:\excel files\[Yearly Expenses.xls]Sheet1'!A1 

By having the worksheet that you are working on, and the worksheet you are going to refer 
to open at the same time, you can use the point method to reference the worksheet.  The 
following instructions place a reference in “Referencing other workbooks and sheets.xls” 
from the workbook “Yearly Expenses.xls”.  These should be open at the same time:  (Hint 
– use the WINDOW, ARRANGE command to place the worksheets side by side). 

1. In cell B14 of “Referencing other workbooks and files”, type an equal sign (=) to 
start off a formula (which also anchors you to this cell while you go to another 
workbook). 

2. Either using the taskbar or the WINDOWS menu, go to the workbook called “Yearly 
Expenses”.  Click in cell B4.  (if you have arranged the worksheets side by side, 
this is where you can simply click in B4 of the Yearly Expenses workbook) 

3. To finish referring to this cell, press the ENTER key on the keyboard or use the 
green . 

 Notice the syntax of the formula is:   ='[Yearly expenses.xls]Sheet1'!$B$4 

 Excel makes the cell or range reference ABSOLUTE when you point and click on 
another workbook.  If you need to copy this to other cells you will need to change 
the reference so it is RELATIVE (no $ signs) – see Page Error! Bookmark not 
defined. for a quick way to change the reference between RELATIVE and 
ABSOLUTE. 

4. Repeat for cells B15, B16 and B17 (Hint: use the fill handle – see Page 14) 

5. If you have both workbooks open, have a look at the syntax of this formula in the 
formula bar of the “Referencing other workbooks and sheets” window.  Now close 
‘Yearly Expenses.xls’, click in cell B14 in ‘Referencing other workbooks and sheets’ 
and have another look at the formula bar.  The syntax has automatically changed to 
include the full pathname of the closed file, which as you can see is very long and 
would be awkward to type accurately. 
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='S:\Common\Special Projects\Training\Client Services\Advanced Excel 
Exercises\[Yearly expenses.xls]Sheet1'!B4 

FILL HANDLE AND FILL SERIES COMMAND 

There are three ways to click and drag on a cell – each having a different effect.   

 

1. When you have the mouse inside a cell, the cursor will be shaped like the Swiss 
Cross.  If you click and drag when this symbol is showing you will select a range of 
cells. 

2. When you point to any border of a cell the cursor changes to a 4-sided arrow (in 
Excel XP) or an arrow (versions prior to XP).  Clicking and dragging with this 
symbol will drag and drop the contents of the cell (to copy instead of move, hold 
down the CTRL key as you drag the contents of the cell). 

3. In the right-hand bottom corner of every cell there is a small square.  If you hold the 
mouse above this, the cursor changes into a thick plus sign.  In this mode, if you 
click and drag, you are using the FILL HANDLE to fill cells you drag over. 

If the fill handle is not showing, go to TOOLS, OPTIONS, EDIT and ensure the ALLOW 
CELL DRAG AND DROP option is enabled. 

The fill handle is a copying tool for copying formulas, and values, however it is also used to 
fill in a variety of series such as sequential numbers, dates and mixed text. 

Examples: 

This Entry Can be extended to 
1,2,3 4,5,6,7 etc 

January February, March, April etc 

Jan Feb, Mar, Apr etc 

Monday Tuesday, Wednesday, Thursday etc 

Mon Tue, Wed, Thu etc 

Qtr 1 Qtr2, Qtr3, Qtr4 

1 June 2 June, 3 June, 4 June etc 

01/04/04 02/04/04, 03/04/04, 04/04/04 etc. 

1st Period, 2nd Period, 3rd Period etc. 

9:00 AM 10:00 AM, 11:00 AM etc. 
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Using the Fill Handle 

The following screenshot shows some typical uses of the fill handle.  Open a blank 
worksheet and try the following fill handle techniques: 

 

A. Type a #1 in A1.  Drag down to A12.  You should end up with all number ones.  
This is because Excel has no idea you want to have a series, i.e. 1,2,3 etc. 

B. Type a #1 in B1.  Hold down the CTRL key and drag down to B12.  You now have a 
series.  The CTRL key makes Excel do the opposite of its natural function when 
using the fill handle. 

C. Monday will drag down the days of the week 

D. The fill handle is case sensitive and will recognise abbreviations. 

E. Here the CTRL key was held down while dragging Monday, hence Excel did its 
opposite function. 

F. Type in a date.  Drag down with the RIGHT mouse button.  When you release the 
mouse, you can select different options from the shortcut menu.  FILL MONTHS 
was selected in this example. 

G. To get a series such as this you need to give Excel a bit of a hand.  In G1 type #5, 
in G2 type #10.  Now select both these cells and drag down with the fill handle.  
Excel now recognises the sequence. 

H. Finally, a trick which is handy especially if it is a very long list you have to drag.  
Type the first entry and then DOUBLE CLICK on the fill handle.  The series will fill 
as far down as the column next to it, so this will not work if there isn’t any data in 
the column next door. 

Using the Fill Series Command 

If you have a specialised or very long list, it may be more efficient to use the EDIT, FILL, 
SERIES option. 
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Examples If you had to have a column numbered 1 to 600, it would be quicker to use 
the EDIT, FILL, SERIES command.  Another example is if you had to have a 
monthly date entered for 25 years (for a mortgage repayment schedule??) 

 

The screenshot above shows the example of having a column numbered from 1 to 600. 

1. Type a #1 in a blank cell. 

2. Click on EDIT, FILL, SERIES 

3. Select either ROWS or COLUMNS (specifies where data will be filled – column is 
the more common). 

4. Excel recognises #1 as being a number and therefore has automatically selected 
LINEAR.   

5. Make sure Step Value = 1, and Stop value = 600 

6. Click on OK to finalise. 

 NOTES: 

 Linear – will create a linear series based on the value you have entered on the 
worksheet.  If the TREND option is cleared, Linear uses the value in the STEP 
VALUE text box.  This value is the amount you want adding each time to the value 
you have on the worksheet – 1 would make it 1,2,3,4 etc.  2 would make it 1,3,5,7 
etc).  STOP VALUE is the value you want to stop at. 

 If TREND is enabled, the STEP VALUE AND STOP VALUE are greyed out.  In this 
scenario you would enter an example of the trend desired in 2 or more cells on the 
worksheet, then select all the cells which you want filling before going to the EDIT, 
FILL, SERIES command.  For example, if you put #5 in cell A1, and #10 in cell A2, 
then select A1:A12, the result would be 5,10,15,20,25,30,35,40…..60. 

 Growth – will create a series whereby the number is multiplied by the number in the 
STEP VALUE.  If you have #1 in cell A1, then go into EDIT, FILL, SERIES and 
select COLUMN, GROWTH, STEP VALUE = 2 and STOP VALUE = 20 the result 
would be 1,2,4,8,16. 
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Customising a Fill Series 

Any list of items that you use constantly can be made into a customised list.  For example 
– a roster of staff members. 

1. If you have a list typed, select the list. 

2. Click on TOOLS, OPTIONS, CUSTOM LISTS 

 

3. Click on the IMPORT button.  The list you selected will appear in the LIST 
ENTRIES window. 

4. If you did not select a list before you entered this option, click in the LIST ENTRIES 
window and type in the list, using a new line for each entry.  When you have 
finished adding items, click on the ADD button. 

5. Click on OK to finish. 

Deleting a Custom List 

1. Click on TOOLS, OPTIONS, CUSTOM LISTS 

2. In the CUSTOM LISTS window select the list to be deleted 

3. Click on the DELETE button 

4. Click on OK to accept the warning that the list will be deleted and then OK again to 
close the CUSTOM LISTS window. 
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CONDITIONAL FORMATTING 

Conditional formatting is extremely useful for things like changing the colour of cells or text 
in order to flag an event.  Formatting occurs when a cell reaches the condition that is set in 
the Conditional Formatting option. 

Example 1 If you are doing a roster, having cells that reach a certain date turn red. 

Example 2 A spreadsheet that has student exam results – having those that Pass turn 
yellow in order to see who should receive a Distinction.  You may also want 
to highlight the “Fail” marks in red so as to flag them for follow up.  The 
instructions for doing this example are below. 

 Creating a Conditional Format 

Steps 1-8 show how to make cells in Column D in the screenshot below change colour if a 
student has passed (using 19 marks or over as the benchmark), (the formula will have to 
refer to the data in Column C to work this out).  Steps 9-10 show how to make the score in 
Column C change colour if a student has 10 marks or less (to show that they have failed). 

A working example of the following has been set up on the CONDITIONAL FORMATTING 
worksheet which is in the Advanced Excel Exercises workbook. 

 

1. Click in the first cell that will have conditional formatting attached (D6) 

2. Click on FORMAT, CONDITIONAL FORMATTING.  The CONDITIONAL 
FORMATTING dialog box will appear. 
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3. Change the first dialogue box to FORMULA IS.  This allows you to enter the 
instructions to refer to another location other than the one you are currently in. 

4. The formula is the condition i.e. to find out if the figure to the left is greater than or 
equal to (>=) the pass mark of 19 .  If you use the pointer to enter the cell address, 
make sure you change it to relative (as a default Excel will make it Absolute). 

 

5. Click on the FORMAT button 

6. In the FORMAT CELLS dialogue box that appears, make all the required changes.  
In the example being used here you would choose the PATTERNS tab, and then 
choose a yellow fill colour for the cell. 

7. Click on OK (twice) to finalise the formatting.   

8. To copy the formatting to the rest of the cells in the column either: 

• use the FORMAT PAINTER ; 

• use the fill handle (use this only if the cell contains a formula) to copy to the 
other cells – beware - if you use the fill handle on cells containing values, you 
will change the values; or 

• use the normal COPY command and then use the EDIT, PASTE SPECIAL, 
FORMATS option to apply to the other cells 

9. To apply conditional formatting to an active cell (in our example, changing the cell 
to red if the student has 10 or less marks) - place the cursor in Cell C6.  Click on 
FORMAT, CONDITIONAL FORMATTING 

10. Select CELL VALUE IS (this will make Excel look at the value of the cell you are 
currently placed in).  Make the changes the same as the screenshot below (the fill 
colour is red).  Click on OK to finish, then copy the formatting to the rest of the 
column as previously described. 
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NOTES: Should you require more than one condition, click on the ADD button.  If you 
want to get rid of a condition, select the DELETE button and then specify which 
condition is to be erased. 

Find Cells That Have Conditional Formats 

• To find all cells that have conditional formatting, click any cell in the worksheet then 
follow the steps 1-3 below. 

• To find cells that have conditional formatting settings identical to the settings of a 
specific cell, click the specific cell, then do steps 1-4 below. 

1. On the EDIT menu, click GO TO.  

2. Click on the SPECIAL button.  

3. Select the CONDITIONAL FORMATS option.  

4. To find cells with identical conditional formats, click SAME below DATA 
VALIDATION (the default is ALL). 
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SORTING AND FILTERING 

Excel’s sorting and filtering functions range from very simple sorts to being able to filter out 
unwanted data in large lists of information.  Lists typed into an Excel worksheet are often 
used as a data source for creating merge documents in Word, or for exporting to other 
databases such as Microsoft Access. 

If you are creating a list that is intended for using with a merge document, the information 
you type is organized into fields (columns) and records (rows).  The fields (the headings of 
each column known as the header row), must be one word i.e. “Firstname” or 
“First_Name” is more correct than “First Name”. 

A list, unlike normal worksheet data, must not have entire blank rows or columns.  
However if information from a record is missing, a cell can be left blank.  

Once a list is created, it becomes easy to sort and filter the information.  It can also be 
used to create pivot tables (not covered here). 

The Excel worksheet, Sorting and Filtering, has been set up to make practicing the 
following sorting and filtering methods more convenient. 

Simple Sorts 

Select any cell in the column that needs sorting, then use the SORT 
ASCENDING or SORT DESCENDING icons on the formatting toolbar.   

Do not highlight the column to be sorted.  If you do, only that column will sort, the rest of 
the data will remain static. 

Sorting on more than one criteria (DATA, SORT) 

The DATA, SORT option is used if you wish to sort on more than one criteria.  For 
example, you may wish to have a sort done on surname, then if there is more than one 
surname the same, sort on the first name, then the city the person comes from.  You can 
have up to three selections using the DATA, SORT option. 

1. Select any cell within the list – this will help Excel 
to select the correct range of cells to be sorted. 

2. Click on DATA, SORT.  The SORT dialog box will 
open. 

3. If your list has a header row, make sure this 
option is selected.  Doing this makes the field 
names appear in the field names drop down text 
boxes. 

4. Select which field names are to be sorted, 
specifying each time whether the sort is to be in 
ascending or descending order. 

5. Click on OK 
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Filtering Data 

Filtered lists allow you to view only the specified data.  This data can then be copied, 
printed etc. 

Example 1: From your list you require a list of all males living in NSW  

1. Click on DATA, FILTER, AUTOFILTER 

2. Drop down arrows appear next to each heading in the list. 

 a) Click on the drop down arrow next to “GENDER” and select “Male”  

 b) Click on the drop down arrow next to “STATE” and select “NSW” 

• Notice that the drop down arrow on both of these fields have turned blue.  This is to 
show that these particular fields have had filters applied. 

• To return each of the columns information back to normal, click on the drop down 
arrow and select “ALL” 

• If you have many columns to restore, it is quicker to click on DATA, FILTER, SHOW 
ALL 

Example 2: You need a report listing everybody who lives in VIC or NSW, and was born 
before 1 January 1985. 

1. Click on DATA, FILTER, AUTOFILTER 

2. Select the drop down arrow next to “STATE” and select CUSTOM 

3. Fill in the CUSTOM AUTOFILTER dialog box the same as the following screenshot 
(make sure you select the OR option, this makes sure you are left with everyone 
who lives in NSW or VIC) 

 

4. Click on OK 

5. Select the drop down arrow next to “DOB” and select CUSTOM 

6. Fill in the CUSTOM AUTOFILTER dialog box as shown in the following screenshot 
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Turning AUTOFILTER off 

When you have finished filtering your data, click on DATA, FILTER, AUTOFILTER (there 
should be a tick next to AUTOFILTER, clicking on this ‘unticks’ the option). 
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MACROS 

Introduction 

Macros in Excel are not macros in the normal sense.  Excel comes with its own 
programming language, Visual Basic for Applications.  This means that very powerful 
macros can be created by almost anyone with the time and patience to construct them. 

A macro is a recording of actions to automate tasks that are tedious or you do frequently.  
Some examples: 

• A macro to open a document you use every day; 
• A macro to add the months of the year across a row, centring and bolding the names of 

the month; 
• A macro to select a group of cells; 
• A macro to find out which cells have Conditional Formatting; 
• A macro to set up a worksheet in a certain way and then print the worksheet. 

Excel provides some useful tools to help beginners to use macros and to start achieving 
results straight away without having to learn much about Visual Basic for Applications. 

The following notes show how to: 

 record a simple macro 
 toggle between absolute and relative references when recording 
 place a macro (assign a macro) on a toolbar icon 
 assign a macro to a button on a worksheet so it is only available to that  

worksheet 
 delete macros 

Recording a macro 

These are instructions for recording a simple macro – selecting a range of cells you need 
to enter data into on a regular basis. 

1. Select TOOLS, MACRO, RECORD NEW MACRO.   The RECORD MACRO dialog 
box will appear. 
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2. In the MACRO NAME text box, type a name for your macro.  Macro names cannot 
include spaces – an underscore is a good way to separate words.  Do not use a cell 
address in the name as this will cause an error. Also, you may not use names of 
commands that already exist, e.g. Close.   We have used Select_Cells for our 
example. 

3. You may wish to give the macro a keyboard shortcut (which is typed in the 
SHORTCUT KEY text box).  You can have a lower case or upper case letter.  If you 
use a shortcut that is already assigned to another function (i.e. CTRL + B has 
already been assigned to BOLD), you will overwrite that shortcut whilst the 
workbook that is storing the macro is open.   

4. Decide where to store the macro  This information gets entered in the STORE 
MACRO IN text box: 

• Personal Macro Workbook – a workbook that is usually hidden from view, a 
macro stored here will be available every time you use Excel, no matter which 
workbook or worksheet. 

• This Workbook – the current workbook.  Useful if the macro you are going to 
record is only to be available when you are using this workbook. 

• New Workbook – Will open a new workbook where you can store the macro.  
You might do this because you want to have a similar macro workbook like the 
Personal Macro workbook – although unlike the Personal Macro workbook, this 
one will not open automatically.  If you want to use the macros stored in this new 
workbook, you would have to physically open it first. 

5. If desired, fill in a brief description in the DESCRIPTION text box – this is for your 
information only.  

6. Click on OK to start the recording process.  You will be placed back in the main 
worksheet.  A STOP RECORDING toolbar should appear (if not, click on VIEW, 
TOOLBARS, STOP RECORDING).  This toolbar has two icons.  An icon to stop the 
recording and one to toggle between recording relative or absolute addresses 
(explained later).  

 The Macro Recorder is active at this stage. The Macro Recorder records all 
keystrokes and commands that you use, so now is the time to be careful as any 
mistakes you may make will also be recorded.  

7. Enter data as normal.  For our example, select a range of cells e.g. F1:G12.   

8. Click on the STOP button to stop recording or alternatively, click on TOOLS, 
MACRO, STOP RECORDING. 
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Running a Macro 

The computer terminology for playing a macro is “Run”.  To run a macro you can use any 
one of the methods following: 

1. Click on TOOLS, MACRO, MACROS (or use the keyboard shortcut ALT + F8), 
select your macro from the list.  Click on RUN;  

2. Use the shortcut key if you created one (our example is CTRL + s);  

4. Use an icon on the toolbar if one has been created for the macro (covered on Page 
28); or 

5. Use a button on the worksheet if one has been created (covered on Page 27). 

 

Absolute vs Relative 

If you followed the example above, run the macro a couple of times from different 
locations.  For example, place your cursor in A1 and run the macro – it will select cells 
F1:G12.  Place your cursor in H12 and run the macro.  It will still select the cells F1:G12.  
This is because the macro you created recorded ABSOLUTE cell references – the default 
way of recording.  If you want to select a range of cells relative to where your cursor is at 
the time of recording, ensure you click on the Relative / Absolute icon on the Macro toolbar 
before commencing to record. 
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Assigning buttons to macros 

Macros can be assigned to buttons or any AutoShape on the worksheet.  These buttons 
will only show on the worksheet that you assign it to and therefore the macro will only be 
available to the worksheet the button is on.   To assign a button: 

1. Make sure the FORMS toolbar is showing (right mouse click over a toolbar that is 
already showing and select FORMS from the list, or VIEW, TOOLBARS, FORMS) 

2. Select the BUTTON shape from the toolbar.   Once 
you have clicked on the shape, go into the worksheet 
and click and drag the mouse until the desired size of 
the button is achieved (this can be edited later if 
necessary).     

3. The ASSIGN MACRO window will immediately 
appear.  Select the macro being assigned to the 
button from the list.  Click on OK. 

4. You will be returned to the Excel worksheet where you 
will see your button with sizing handles around it.  You 
can change the text inside the button by dragging over 
the text and retyping. 

 

a) To resize, hold mouse over a sizing handle and drag in or out 

b) To retype label drag over text, then type.  If the button is not selected, select it 
by: 

• Holding down CTRL key and clicking on the button; or 
• Click on the button with Right Mouse button and select EDIT TEXT. 

NOTE:  Do not use left mouse button to select the button as this runs the 
macro. 

c) To move the button, click and drag on the frame surrounding the button, avoid 
dragging on the sizing handles.  

5. Once you click away from the button you have created, it becomes active and will 
run the macro assigned to it when clicked on. 

Assigning the macro to an AutoShape 

1. Draw an AutoShape on your worksheet. 

2. Format the AutoShape in any way you like e.g. borders and patterns. 

3. Add descriptive text to the AutoShape (right Mouse click on the AutoShape and 
select ADD TEXT) 

Sizing handles (used 
for resizing object 
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4. Right mouse click on the AutoShape and select ASSIGN MACRO (if Assign Macro 
is not available try clicking on the frame surrounding the AutoShape again, it should 
be made up of tiny dots, not diagonal lines. 

 

 

 

 

 

 

 

5. The ASSIGN MACRO window will immediately appear.  Select the macro being 
assigned to the AutoShape from the list.  Click on OK. 

6. When you deselect the AutoShape, it becomes active and will run the macro 
assigned to is when clicked on. 

Assigning a macro to an icon on a Toolbar 

Macros can be assigned to icons on an existing toolbar or on a new toolbar.  This macro 
will be available whenever you open a worksheet showing that toolbar. 

1. Use either the VIEW, TOOLBARS, CUSTOMIZE command or click on any toolbar 
with the right mouse button and select the CUSTOMIZE option.   The CUSTOMIZE 
dialog box will appear. 

2. Choose the COMMANDS index card and select MACROS from the CATEGORIES 
listing text box. 

 

If the frame surrounding the object is made up of 
diagonal lines, click on the frame again so that is 
made up of tiny dots.  “Assign Macro” will then 
be active in the shortcut menu
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3. Click on the CUSTOM BUTTON (the smiley face) in the COMMANDS window and 
drag and drop this icon on to the desired toolbar, in the desired location. 

4. Click with the Right mouse button on the icon you have just put on the toolbar and 
select the ASSIGN MACRO option from the shortcut menu.  Select your macro 
from the list. 

5. Optional - to change the button image, make sure the CUSTOMIZE dialog box is 
still on the screen, then use the Right Mouse button over the icon you want to 
change, choose CHANGE BUTTON IMAGE from the menu.  Choose a new icon. 

6. Close the CUSTOMIZE dialogue box. 

Viewing The Macro 

1. Once you have recorded your macro you may view it by Selecting TOOLS, 
MACRO, MACROS.  The Macro Dialogue box will appear. 

2. Select your macro from the list and then click on the EDIT button 

This displays the module containing the text of the macro in Visual Basic.  Once you have 
gained experience, simple editing changes can be made inside the Visual Basic Editor. 

Deleting a Macro 

1. Open the TOOLS, MACRO, MACROS dialog box. 

2. Select the macro to be deleted, then click on the DELETE button. 
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LOOKUP TABLES 
(Using VLOOKUP as example) 

The functions VLOOKUP and HLOOKUP enter information into a spreadsheet from a table 
made up of possible values.  The result can be a value or text.   

The advantages of using VLOOKUP and HLOOKUP are: 

• They avoid the need for repetitious data;  
• Cuts down on the possibility of entering data incorrectly; and 
• Allows automatic updating of entries by changing the values in the lookup table. 

Example: Imagine having to work out staff allowances for 100 staff, each entitled to a 
return airfare to their home town each year.  If you enter a value next to each 
staff member for the price of the airfare, and the airfares change (as they do), 
you would have to change each value every time the airfares changes.  By 
using VLOOKUP, only the airfares in the lookup table are updated. 

 

 

Figure 1 - Airfares entered manually

Figure 2 - Airfares 
using a VLOOKUP 
formula – if the 
airfares change 
then only the 
amounts in 
column H will be 
changed – the 
amounts in 
column C will 
update 
automatically. 
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VLOOKUP function (see Figure 2), looks up a value from the LEFT most column of a 
table.  This function is used when your data is arranged in columns. 

HLOOKUP function looks up a value from the top row of a table.  HLOOKUP is used when 
your table is arranged in rows. 

Syntax: VLOOKUP(lookup_value,table_array,col_index_num,range_lookup) 
 HLOOKUP(lookup_value,table_array,row_index_num,range_lookup) 

 The bold part of the formula above is required, the last bit is optional. 

lookup_value refers to a cell in the main part of your worksheet whose information 
also appears in the first column (or row if using HLOOKUP) of your 
table.  Using Figure 2 as an example, the lookup value for the first staff 
member is cell B5 (Melbourne).  This information is also found in the 
first column of the Lookup table (the table you are going to refer to, to 
get the amount of the airfare). 

 The lookup value can be text, a value or a cell reference. 

table_array refers to the reference table from which you are going to get 
information.  When referring to this table you should refer to an 
ABSOLUTE range (in Figure 2 the table’s range is $G$5:$H$12).  You 
can also refer to a Range Name.  If you give the table a range name, 
by default the cells will be absolute.  Having an absolute range ensures 
that the formula always refers to the same set of cells making up the 
table when copying. 

 The first column (or first row) of the table can be text, numbers or 
logical values.  It doesn’t matter if it is uppercase or lowercase.  The 
first column (or row) should be in either numerical or alphabetical order, 
it can be sorted using the DATA, SORT menu 

col_index_num The third part of the function is asking which column of the reference 
table do you want your answer to come from.  In Figure 2 the table is a 
2-column table and we want the answer to be the amount of the airfare, 
therefore in this case the col_index_num would be 2. 

 If the col_index_num is less than 1, you will get a #VALUE error. 
 If col_index_num is more than the number of columns in the table, 

you will get a #REF! error. 

range_lookup The 4th part of the formula is optional depending on the answer you 
want.  If you require an exact match, use FALSE.  If you want an 
approximate match, leave this option out or use TRUE (they are the 
same). 

 For example (refer to Figure 3), Denise Roe’s home town has been 
changed from Perth to Deniliquin.  The fourth part of the LOOKUP 
function has been made to say TRUE and will therefore look up an 
approximate match.  Deniliquin is not in the table of airfares therefore 
the formula returns the nearest match which is less than or equal to 
what is being looked up (Deniliquin).  Darwin is the nearest match, 
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slightly lower in the alphabetical scale.  This formula would be 
unsuitable in this case because hopefully the airfare to Deniliquin 
would be nowhere near the amount of $799.00.  FALSE should have 
been used in the fourth part of this function. 

 

Figure 3 - Finding an Approximate Match 

NOTES: • When TRUE is used, or the range_lookup is omitted, the VLOOKUP 
and HLOOKUP will return the largest match which is less than or 
equal to the lookup_value. 

 • If using FALSE and exact match is not found, a #N/A error is returned. 

 • If lookup_value is smaller than the smallest value in the first 
column/row of the table, you will get a #N/A error. 

 • When referring to the table range, the range should be made to be 
ABSOLUTE.  i.e. highlight the table (do not include headings), press 
F4 until the range has “$” signs in front of column and row references 
e.g. $G$5:$H$12. (F4 is the shortcut key to toggle between different 
sorts of addresses – relative, absolute and a combination of the two.  
A way to remember this shortcut key is that the normal number 4 has 
the $ sign above it). 

 • Consider giving the table a range name.  Using the airfare example, a 
good name would be “Airfares”.  As a default range names are made 
absolute.  See pages 7 to 9  on how to name ranges.  

 • The table can be put on the same worksheet as your data however 
you should take into account security issues.  If you don’t want just 
anyone changing the core data of the table you might wish to put the 
table on a different worksheet or even in a totally different file.  See 
Pages 12 to 13 for instructions on how to reference other worksheets 
or files.  
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Creating the VLOOKUP Function 

To practice the VLOOKUP formula, open the read-only file Advanced Excel Exercises and 
go to the VLOOKUPS worksheet.  Use the FILE, SAVE AS command to save this file in a 
different name in your P:\DATA folder. 

 

 

1. Place your cursor in the cell where the first result will be (C5 using the example 
above). 

2. Use the instructions on Pages 2 to 5 to get the VLOOKUP FUNCTION 
ARGUMENTS dialog box showing on your Excel worksheet. 

 

3. The Lookup_value is asking you to refer to a cell in the main part of your 
worksheet, that has the data that also appears in the first column of the reference 
table.  Using our airfare example, B5 has this information.  B5 has the text 
“Melbourne”.  Melbourne also appears in the first column of our reference table.  If 
you can see B5 on your spreadsheet, click on it.  This cell address will then appear 
in the first reference.  (Use the COLLAPSE DIALOG icon if you can’t see the 
spreadsheet behind the FUNCTION ARGUMENTS dialog box, or move the dialog 
box by dragging on the title bar). 
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4. Table_array is asking for the details about the table.  Highlight the entire table, do 
not include any headings.  When the range address appears in the reference area, 
use the F4 key to make the range ABSOLUTE (each column and row reference has 
a “$” sign in front of it); or   

If you have previously given the table a RANGE NAME, use F3 to bring up the 
PASTE dialog box, select the table name from the list.  (See pages 7 to 9 for more 
about Range Names.)  If the table is on another sheet or file, see pages 12 to 13  
for Referencing other Sheets or Files. 

5. Col_index_num is asking for the number of the column in the table the result is to 
come from.  In our example, the table has only 2 columns and the prices of airfares 
are in the second column, therefore type the number 2 in the third reference area. 

6. Range_lookup is optional (notice the text is not bold like the compulsory 
arguments).  If you want an exact match, type FALSE in here.  If you want an 
approximate match, leave it blank or type TRUE.  In our example you would need 
an exact match.   

If you are doing the VLOOKUPS exercise, try leaving this option blank and then 
look at Row 10 and Row 17 of the example.  Denise Roe’s airfare would read 
$799.00 – the amount someone flying to Darwin would receive.  Joe Bloggs’ airfare 
would read $400.00.  Deniliquin and Alice Springs are not mentioned in the airfares 
table so it used the nearest matches – Adelaide and Darwin.   Fill the option in with 
“FALSE”.  You will now have a “#N/A” error.  This will serve to draw your attention 
to the fact that Alice Springs and Deniliquin both need to be added into the table 
information. 

7. Click on OK to finish the function.  If filling several cells with this formula, use the 
FILL HANDLE to drag down to the other cells.  (see Page 14 to read more about 
the FILL HANDLE) 

 Note:  In the example used, NEW STAFF entries should have #N/A errors.  As 
soon as a new staff member and city is added, the prebuilt formula will immediately 
show the amount of airfare (if the city is mentioned in the table). 

If you are putting formulas in a worksheet where no data has yet been entered 
(such as the NEW STAFF in our example) #N/A errors will occur.  This type of 
error can be ‘hidden’ by using the ISNA or ISERROR function.  See page 48 
for step by step instructions on using this function. 

If you add new data to the table, your range address used in each formula will 
have to be changed to include the new cells of the table.  If you used a range 
name this will be taken care of automatically if you ensure that the new data 
falls within the boundary of the range name – you can check by looking at the 
reference in the INSERT, NAME, DEFINE dialog box.  As a hint, if you add a 
couple of rows in the middle of the table, add the new data then re-sort the 
first column of the table into alphabetical/numerical order, the new data will be 
confined within the boundaries of the range name. 
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IF FUNCTION 

The IF function is located in the LOGICAL category of functions in Excel.  Its job is to do a 
conditional test on criteria then return different answers depending on whether the results 
of the test are true or false. 

The conditional test can be made on values, text or on formulas 

Example1: A typical example is that of a lecturer giving a PASS to a student having a 
score of 10 or more in an exam, and a FAIL if they have a score less than 
10.  The logical test is to find out what their score is, then return a PASS or 
FAIL depending on the outcome of the test.   

Example 2: Staff in a hardware store receive 5% commission if they achieve budget.  
The logical test is to find out whether they have achieved budget and then 
give them 5% commission if they have, no commission if they haven’t. 

Working examples of the above can be found in the Advanced Excel Exercises workbook, 
on the IF FUNCTIONS worksheet. 

Syntax: 

IF(logical_test,value_if_true,value_if_false) 

logical_test is the test performed on a value or expression.  The result of the test 
must be able to be evaluated to TRUE or FALSE.  The logical test uses 
comparison calculation operators e.g: 

 = equal to 
 > greater than 
 < less than 
 >= greater than or equal to 
 <= less than or equal to 
 <> not equal to 

 Using the example screenshot below, Julia Richards has a score of 15 
in her exam, the logical test would be to find out if C6 is greater than or 
equal to 10 (shown as C6>=10).  In this case, the answer would be 
TRUE, cell C6 is greater than 10.  Julia Richards will get a PASS. 

 

 In the second screenshot, the logical test would be to find out if the 
cells in column B are greater than the sales target found in cell B21.  
The logical test is to find out if B25 is greater than or equal to the 
amount found in cell B21 (B25>=$B$21).  It isn’t greater so the answer 
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would be FALSE.   (Note how B21 has been made absolute so that 
when the formula is copied down, each line will refer to the amount in 
B21.  The first staff member has not reached or equaled the sales 
target and therefore will not get the 5% commission. 

 

value_if_true is one of the values that can be returned from the logical test. 

 If you want the answer to be “True”, then the text “TRUE” would be 
used (can be lower or upper case).  Any text can be used, just make 
sure it is enclosed in double quotation marks (“text to be returned”). 

 If you want the answer to be nothing, leave the argument blank or type 
"".  (In Excel text expressions are enclosed within double quotation 
marks). 

 You can use another formula if the answer is true i.e. sum figures or 
multiply by an amount. 

value_if_false  is the other value that can be returned from the logical test.  The same 
arguments as for value_if_true are used except if you want “False” to 
be returned, type the text “FALSE”. 

Creating the IF Function – Example 1 

Use the IF function to work out whether students have a Pass or Fail (P or F). 

1. Place your cursor in the cell where the result will be (D6 using the worksheet from 
the Advanced Excel Exercises).   

2. Use the instructions on Pages 2 to 5 to get the IF FUNCTION ARGUMENTS dialog 
box showing on your Excel worksheet. 

 

Message 
showing 
current 
result of 
your logical 
test 
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3. The Logical_test is where you put your argument – which must return an answer of 
true or false.  In the above figure we refer to Julia Richards’ exam result in C6 and 
ask if it is greater than or equal to 10.  Note the “TRUE” message. 

4. Value_if_true – Type the word “Pass” (If using the Function Wizard the double 
quotation marks are automatically typed in for you).  Note the result at the right-
hand side of the dialog window.  This is the result you will get if the argument is 
TRUE. 

5. Value_if_false – Type the word “Fail”.  This is the result you will get if the argument 
is FALSE. 

 

6. Click on OK to finish the function.  If filling several cells with this formula, use the 
FILL HANDLE to drag down to the other cells.  (see Page 14 to read more about 
the FILL HANDLE) 

NOTE: The arguments are not always text, it can be another formula or a value, or if a 
null (no result) is required, nothing (or “”.  i.e. nothing between the double 
quotation marks). 

Creating the IF Function – Example 2 

The second example – using sales commission, requires a formula to be used.   

Results that 
will be used 
after the 
logical test 
has been 
completed. 
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In this case the Logical_test is asking if the value in B25 (on the IF FUNCTIONS 
worksheet) is greater than or equal to B21 (the target the salespeople have to achieve in 
order to get any commission, note that this reference is Absolute). 

The Value_if_true is saying if the target is achieved, multiply the amount by 5%. 

The Value_if_false is saying if the target is not achieved, give 0 commission. 

Manually Creating an IF Function 

Once you are confident with IF functions you may decide to type the formula rather than 
use the FUNCTION ARGUMENT dialog box.  Just remember: 

• To use =IF as the function 

• Inside the parenthesis (brackets) you have 3 arguments which MUST be separated by 
commas (,) 

• If you require a result to be text, the text must be enclosed inside double quotation 
marks e.g. “Pass” or “Fail” or "" (the latter is to have no text appear)). 

=IF(B25>=B21,B25*5%,0) 

or 

=IF(B25>=B21,B25*5%,"") 
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NESTED IF FUNCTION 

Occasionally a single IF statement may not be enough to give you the results you are 
looking for.  The traditional example of this is taking the student example a little further.  In 
the figure below, (which is in the Advanced Excel Exercises workbook), Column D is the 
normal IF function done in the last exercise which finds out whether the student has 
passed or failed.  Column E, however, is asking what grade the student is to receive based 
on the following table: 

A   = 17-20 
B   = 14-16 
C   = 11-13 
D   = 8-10 
E   = 7 or below 

 

 

The normal IF Function will not give you the required result.  You need more than one IF 
function to complete the job – you can do this with a NESTED IF FUNCTION i.e. more 
than one IF Function, one inside the other (you are allowed up to 7 nested functions). 

Put in simple terms, our nested IF statement is going to be: 

First IF statement: 

Logical test – see if C6 is a value of 7 or below (C6<=7) 
If true –  Give an “E” grade 
If false –  see IF C6 is a value of 10 or below to work out whether this student should 

have a “D” grade – this will lead to the second IF statement 

Second IF statement: 

Logical test - see if C6 is a value of 10 or below (C6<=10) 
If true - Give a “D” grade 
If false -  see IF C6 is a value of 13 or below to work out whether they should get a “C” 

grade – this leads to the third IF statement 

Third IF statement: 

Logical test - see if C6 is a value of 13 or below (C6<=13) 
If true - Give a “C” grade 
If false -  see IF C6 is a value of 16 or below to work out whether they should get a “B” 

grade – this leads to the fourth (and last) IF statement 

Fourth IF statement: 

Logical test - see if C6 is a value of 16 or below (C6<=16) 
If true - Give a “B” grade 
If false -  it must be true that C6 is between 17 and 20 as there are no other possible 

marks left.  Therefore “A” should be entered here to indicate the top grade 
possible. 
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Each statement above has a logical test, then a value_if_true, then a value_if_false.  The 
step by step instructions, using the FUNCTION ARGUMENT dialog box and the scenario 
about a student’s grades as an example are: 

1. Ensure your cursor is in Cell E6.  Call up the IF FUNCTION ARGUMENT dialog 
box. 

2. Put in the first logical test (point and click on Cell C6 then type <=7) and the 
Value_if_true result (the student would get an “E” if true). 

 

3. Make sure your cursor is in the “Value_if_false dialog box.  Now click on the IF 
function in the name box to bring up a brand new FUNCTION ARGUMENTS dialog 
box. 

 

 

 

4. In the new FUNCTION ARGUMENTS dialog box, type in the next argument, and 
the Value_if_true result (see if the student has a mark of 10 or less, and if so give 
them a “D”). 

1.  Fill in the 
first two 
dialogue boxes

2.  Then click in the 
“Value_if_false” 
dialogue box 

Click on the IF function to 
create a new FUNCTIONS 
ARGUMENT dialog box 
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5. Repeat Step 3 

6. Repeat Step 4 but this time the logical test is to see if the student has a mark of 13 
or less.  If it is TRUE, they will get a “C” 

 

7. Repeat Step 3 to bring up a final FUNCTION ARGUMENTS dialog box.  This is the 
only tricky part, knowing when to stop asking for more new arguments.  Here the 
final logical test is entered (C6<=16).  Notice that the result of this argument is 
TRUE.  The Value_if_true is a mark of B.  The value_if_false must therefore be 
someone who has more than 16 marks and gets an “A”. 

 

8. Click on OK to finish the function.  If filling several cells with this formula, use the 
FILL HANDLE to drag down to the other cells.  (see Page 14 to read more about 
the FILL HANDLE) 

If you were to manually type the above formula it would look like: 

=IF(C6<=7,"E",IF(C6<=10,"D",IF(C6<=13,"C",IF(C6<=16,"B","A")))) 

As you can see it looks a little complex, just remember that you must have the right 
amount of parenthesis in the right order, and commas separating the arguments.  Usually 
this sort of formula is easier to create using the FUNCTION ARGUMENTS dialog boxes. 

This 
argument is 
TRUE 
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AND, OR AND NOT FUNCTIONS 

The AND, OR and NOT functions, like the IF function, are found under the LOGICAL 
category of functions available in Excel. 

Although they can be used in their own right, these functions are most often found being 
used to increase the logical comparisons you can make within an IF function. 

The AND and OR Functions 

Both of these functions can have up to 30 arguments.  The difference between them is 
that: 

• with an AND function, all arguments MUST be TRUE, to return a TRUE result.  Only 
one comparison needs to be false to make the result FALSE.   

• With an OR function, only one of the comparisons needs to be TRUE to return an 
answer of TRUE. 

Example 1 (Using the AND function) - Using a Sales Commission example, an 
employee gets a 10% bonus commission when his sales meets a target 
($1,500) AND he has worked for the company for 2 or more years (2 
comparisons).  If these comparisons are true he gets the 10% bonus, if he 
doesn’t meet these conditions he gets a 5% bonus as long as he has sales 
of $500 or more (another IF function).  If sales are less than $500, the 
commission is zero. 

 If we do an OR function using the same example, we would get a different 
result,  What we would be saying is an employee gets a 10% bonus if he 
reaches the $1500 target OR he has worked for the company for 2 or more 
years.  Therefore in this case he would get his 10% bonus commission if he 
only has sales of $1,000. 

Syntax: =AND(logical1,logical2,……….logical30) 
 =OR(logical1,logical2,……….logical30) 

logical#  the comparisons you make, (each to be separated with a comma) up to 30 
are allowed as long as does not exceed 1,024 characters in total. 

A working example of the above can be found in the Advanced Excel Exercises workbook, 
on the AND, OR, NOT worksheet. 

Creating the AND function within an IF statement 

1. Ensure your cursor is in Cell D8.  Bring up the IF FUNCTION ARGUMENT dialog 
box. 

2. In a normal IF Function we would be using only one conditional test here.  However 
we have two tests to make so we use the AND function.  You have a choice of 
either manually typing the AND function in the Logical_test dialog box, or using the 
AND FUNCTION ARGUMENTS dialog box.  If using the latter, make sure the 
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cursor is in the Logical_test dialog box then click on the drop down arrow on the 
Name Box (which should have the word “IF” on it), and select the AND function 
from the list (go into MORE FUNCTIONS if AND is not in the list). 

 

 

 

3. The AND FUNCTION ARGUMENTS window appears.  Your cursor should be in 
the Logical1 dialog box.  Click in B8 (the first sales figure), type in “>=” and then 
click in B5 (the sales target figure).  After clicking in B5, press the F4 key to make 
B5 absolute.  (If you don’t, when you copy the formula down to other rows, B5 will 
change to B6, then B7 and so on.  This reference must always be talking about the 
figure in B5).  Logical1 should now read B8>=$B$5 

Step 1 - Make sure 
your cursor is in the 
Logical_test dialog 
box 

Step 2 – Click on 
the drop down 
arrow here  

Step 3 – Select 
the AND function 
from the list or go 
into “More 
Functions” if AND 
is not in the list.  
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4. Click in the Logical2 dialog box (notice that Logical3 automatically gets added).  
The second comparison is now entered.  Click in C8 (the amount of years the staff 
member has worked for the company), type “>=”, finally type the number 2.    

 

5. Click on OK.  Excel now believes you have finished the formula and returns you to 
the worksheet.  However there is an error (because the formula has not been 
finished), the following message will appear. 

 

6. Click on OK to get rid of the message.  To bring the FUNCTION ARGUMENTS 
dialog window back up, click in the formula bar where the IF function part of the 
formula is, and then click on the FX button.   

 

7. The IF FUNCTION ARGUMENTS window will reappear, with the AND function 
information in the Logical_test dialog box. 

NOTE: If you want to manually type in the AND Function, replace Step 2 by typing 
in the function name, open the brackets and put in the arguments, each 

Step 1 – Click in the “IF” 
part of the formula Step 2 – Click on 

the fx button 
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separated by a comma.  End by closing the brackets.  (Don’t forget to 
make the reference to B5 absolute.  Go to Step 8 when you have done 
this.  Your value_if_true should read:   

AND(B8>=$B$5,C8>=2) 

8. In the Value_if_true dialog box, type in the TRUE result – i.e. click in B8 to select 
the sales amount then type “*10%”.  Value_if_true should then read  B8*10% 

 

9. The Value_if_false is another IF function – to find out IF the salesperson has 
earned $500 or more.  Making sure your cursor is in the Value_if_false box, go and 
request another IF Function.  Use the instructions in Step 2 which show you where 
to click to request another function. 

10. Fill in the details as shown in the following screenshot (note that Value_if_true is 0 
– they get no commission if sales are less than $500). 

 

11. Click on OK to finish the function.  If filling several cells with this formula, use the 
FILL HANDLE to drag down to the other cells.  (see Page 14 to read more about 
the FILL HANDLE) 

If you were to manually enter the above formula it would look like: 

IF(AND(B8>=$B$5,C8>=2),B8*10%,IF(B8<500,0,B8*5%)) 
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Creating the OR function within an IF statement 

Repeat all of the above instructions but using the OR function rather than the AND 
function.  Note that the results are different.  This is because anyone achieving either of 
the comparison tests (earning over $1500 OR having worked for 2 or more years), will 
earn them a 10% bonus. 

The NOT function 

The NOT function only has one argument.  Again it can be used on its own, but is usually 
used in conjunction with an IF function.  Whereas most of our logical functions return 
TRUE if the argument is true, and FALSE if the argument is false, the NOT function 
returns FALSE if the argument is true, and returns TRUE if the argument is false. 

Syntax:  =NOT(logical) 

Example: Using the Pass/Fail of students example, a letter must be sent to the 
students who failed.  To aid in flagging these, a formula is created to put the 
word “Send” next to those who have failed.    

A working example of the above can be found in the Advanced Excel Exercises workbook, 
on the AND, OR, NOT worksheet. 

 

1. Create an IF Function and fill in the following details by going and calling in a NOT 
FUNCTION ARGUMENTS window using the method described previously.  
Remember that any text you request must be enclosed in double quotation marks. 
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2. Click on OK to finish the function.  If filling several cells with this formula, use the 
FILL HANDLE to drag down to the other cells.  (see Page 14 to read more about 
the FILL HANDLE) 

If you were to manually enter the above formula it would look like: 

=IF(NOT(D21="Pass"),"Send","") 
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ISNA AND ISERROR FUNCTIONS 

When doing IF and LOOKUP Functions (amongst others) you may be left with #N/A or 
#REF! error codes that look unsightly or "clutter" up the page.  In the VLOOKUP example 
formulas have been built in for Staff not yet employed.  #N/A errors will disappear as soon 
as a Home Town has been added to column B.  #N/A errors occur if there is no 
information available to make the formula work.   

 

The ISNA and the ISERROR functions allow you to use other functions without returning 
an error.  Instead you can have a "0" appear or alternatively an empty cell (or any text you 
enclose within double quotation marks).  This would be useful, for example, when 
information is yet to be added i.e. you have formulas entered for a budget using January 
through to December.  If the current month is March error codes will probably appear in 
April through to December cells.  It would look better to have them blank (or with a "0"). 

The ISNA command avoids the #N/A code. 

The ISERROR command enables you to avoid the #N/A, #VALUE!, #REF!, #DIV/0!, 
#NUM!, #NAME? and the #NULL codes. 

Syntax: 

=IF(ISERROR(VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)),"", 
VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)) 

=IF(ISNA(VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)),"", 
VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)) 

This would be quite complex to enter manually.   A working example to practice and 
demonstrate using the ISERROR function is located in the Advanced Excel Exercises 
workbook.  Click in C5 in the workbook and follow the steps below: 
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1. Highlight the formula in the formula bar (without the "=" sign).  Copy this formula 
(use the copy icon or CTRL + C) 

 

 

2. In front of the VLOOKUP formula, BUT after the "=" sign, type IF(ISERROR( 

 

 

3. Now hit END on the keyboard to go to the end of the formula.  Type ),"", (if you 
want the cell to be blank) or type ),0, (if you want a "0"). 

 

 

4. Paste in the formula you previously copied (use paste icon or CTRL + V). 

 

 

5. Finish off by typing a closing ) 

 

 

6. Use the ENTER key to finish the function.  If filling several cells with this formula, 
use the FILL HANDLE to drag down to the other cells.  (see Page 14 to read more 
about the FILL HANDLE)  Those cells that previously had an error code should now 
be blank. 
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WORKING WITH TEXT 

There are many functions under the TEXT category and once you have worked with a few 
the others are quite easy to follow.  Some of the more common text functions are: 

• LOWER • PROPER • UPPER 
• MID • RIGHT • LEFT 

 
 A B C 

1 Richards julia  
2 Thompson sarah  
3 Smith fred  

 
Syntax Description Example 
=lower(cell address) Gives you the text all in lower 

case 
=lower(A1) would return 
"richards" 

=upper(cell address) Returns text string in upper 
case 

=upper(A1) would return 
"RICHARDS" 

=left(cell address) Returns the leftmost character 
in a text string 

=left(A1) would return "R" 

=right(cell address) Returns the rightmost 
character in a text string 

=right(A1) would return 
"s" 

=mid(cell_address,whe
re_to_start,how_many_
characters_ to_return) 

Returns characters from a 
specified point in the text 
Has 3 arguments.  
1. Cell address 
2. Which character to start 
from (first character is no 1) 
3. How many characters do 
you want to appear 

Example - to return the 
1st three letters of the 
surname 
=mid(A1,1,3) would 
return "Ric" 

=proper Makes the first letter of 
character string uppercase 

=proper(B1) would return 
"Julia" 

Nested Text Functions 

If nesting text functions (having more than one function in the same formula) ensure you 
enter the formulas in the right order. 

For example:  If you wanted the first 3 letters of the surname in Lower case: 

Right Way: =lower(mid(A1,1,3))   would return "ric" 
Wrong Way: =mid(lower(A1,1,3))   would return an error 

For more text functions look up TEXT FUNCTIONS in the help menu.  Also, a practice 
exercise has been set up in the Advanced Excel Exercises.xls workbook, on the Text and 
Concatenation worksheet. 
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CONCATENATION 

concatenation (-n-k-), n. Connexion as of chain-links, string or series of or of ideas, events, 
&c.  

Oxford Dictionary 

The CONCATENATE function joins strings of text together.  It is often used when working 
with databases but is also useful for consolidating information.  There are two methods of 
concatenating text, with the CONCATENATE function or by using the & operator.  Both 
are explained here. 

Example  When doing consolidations where you have to combine information, you 
may end up with a list where items often mean the same thing e.g. imagine 
working with two different companies each with their own expense sheet.  It 
is your job to bring the expenses together in a consolidated expense sheet.  

Dodgy Brothers    Sweet Tooth Cafe 
 Wages Telephone 
 Electricity Communications 
 Power COGS 
 Rent Lease 
 COGS Salaries 

  In a consolidated expense sheet this may look better presented as: 

 Wages & Salaries 
 Electricity & Power 
 Rent & Lease 
 Telephone & Communications 
 COGS & COGS 

 COGS would look unusual being mentioned twice so we have combined it 
into one listing, using an IF function.  See example 2. 

The listing for the consolidated information could be typed as ordinary text, however you 
would be breaking a basic rule of spreadsheeting - Do not repeat information, use cell 
references.  If you change the ORIGINAL text in any way whatsoever, the change will 
automatically be reflected in the Consolidation if you use Concatenation to combine the 
information. 

In the following detailed instructions there are two ways of handling concatenation, one 
where words are combined (Electricity and Power) and one where the listing is only 
mentioned once (COGS).  An exercise has been set up for your convenience and can be 
found in the working example Consolidation.  The first two worksheets belong one each to 
Dodgy Brothers and Sweet Tooth Café, the third worksheet is the consolidation where you 
can concatenate the cells. 

Example 1 - Combining two entries using the & operator 

Join the two cell references with &" and "&  
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In the following screenshot, Wages and Salaries have been combined - notice the formula 
in the formula bar. 

 

In Excel you normally have operators such as +, -, / or * between cell references, which 
asks Excel to add, subtract, divide or multiply the contents of those cells.  In this scenario 
however, we are joining two cells that contain text.  The & symbol is the operator used for 
joining cells with text.  They are usually in pairs so that in between the symbols you can 
indicate what text you want to join the words (a space or words, punctuation etc).  This text 
must be enclosed in double quotation marks – “” 

1. Using the Consolidation workbook as an example, make sure you are in Cell A5 on 
the CONSOLIDATION worksheet. 

2. Type an “=” sign (the beginning of every formula). 

3. To get the first cell which contains the word “Wages”, click on the DODGY BROS 
worksheet tab at the bottom of the window, then click in A5, the cell address 
'Dodgy Bros'!A5 should be in the address bar. 

4. Type an ampersand (a & symbol, found above the number 7 on the keyboard).  
This tells Excel you are going to add some text or point to another cell containing 
text.   

5. We want some text between the words “Wages” and “Salaries”.  This text is a 
space, followed by the word “and” followed by another space. 

 After the & you just typed, type “ and “  (a double quotation mark, a space, the 
word “and” and then another space, close the quotation marks). 

 Any text you want between cells MUST BE ENCLOSED IN DOUBLE QUOTATION 
MARKS. 

6. Type another &.  This tells Excel you are ready to point to another cell. 

 The &"...................."& is the way to combine cells containing text with whatever text 
or symbols you place between these characters - in our case with a space, the 
word "and" and another space. 

7. Click on the SWEET TOOTH CAFÉ worksheet tab.  Then click in cell A5 (the cell 
containing the word “Salaries”. 

8. To finalise the formula, click on the Green  or hit ENTER on the keyboard. 
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9. Repeat the above instructions to create the Electricity & Power, Rent & Lease and 
Telephone & Communications cells.  (if you were sure they were entered in the 
same order on both worksheets, you could use the Fill Handle to copy the formula). 

Example 2 – By using an IF function, combine two entries, ending up with one entry 

In the case of the COGS entry, combining them as in the first example, we would end up 
with COGS and COGS which is exactly the same thing and would not look very 
professional.  By using an IF function we can say make Excel show COGS only once, but 
if the original text changes then reflect that change automatically.  

 

1. Ensure you are in Cell A9 of the CONSOLIDATION worksheet. 

2. Call up an IF FUNCTIONS ARGUMENTS window. 

 

3. Logical_test 
• click on DODGY BROS worksheet and select A8. 
• Type an “=” sign 
• Click on SWEET TOOTH CAFÉ worksheet and select A8. 

 i.e. you are asking “is the cell A8 in Dodgy Bros the same as cell A8 in Sweet Tooth 
Café”.  Note in the screenshot above, the result of the logical test is “True”.  The 
cells are the same as each other. 

4. Value_if_true 
• Click on DODGY BROS worksheet and select A8. 

i.e.  if the cells are the same, you only wish to have the word “COGS” appear once. 
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5. Value_if_false 
• Click on DODGY BROS worksheet and select A8 
• Type the following &” and “& 
• Click on SWEET TOOTH CAFÉ worksheet and select A8 

 i.e. if the cells aren’t the same, show the contents of the two cells joined by the text 
“ and “  

6. Click on OK to finish the formula. 

To see if this works correctly, try going to the DODGY BROS worksheet and changing Cell 
A8 to read “Cost of Goods Sold”.  Go back to the CONSOLIDATION worksheet and see 
if the cell containing COGS now reads “Cost of Goods Sold and COGS” 

Example 3 – Using the CONCATENATE Function 

The text cells can be joined by using the CONCATENATE function, which is found under 
the TEXT category of functions. 

1. Call up a CONCATENATE FUNCTION ARGUMENTS window 

 

2. In Text1, click on DODGY BROS worksheet and select A8.  Then click in Text2.  
Note Text3 automatically appears (you can join up to 30 strings of text) 

3. In Text 2 type a space, then the word and,  then type another space.  

4. Click in Text3 – note how the double quotation marks have been added 
automatically for you in the Text2 dialog box 

5. Click on SWEET TOOTH CAFÉ worksheet and select A8 

6. Click on OK to finalise the formula. 

To fix up the problem of COGS appearing twice, you would have to create an IF function 
and when you get to the “VALUE-IF_FALSE” section, call up a CONCATENATE function 
and fill in as per instructions above.   

The final step to completing the exercise is to bring across the figures for DODGY BROS 
and SWEET TOOTH CAFÉ.  These will be normal formulas – do not retype the figures 
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because if the original figures change, the retyped ones on the CONSOLIDATION 
worksheet will not change.  By using the following instructions the consolidation figures will 
automatically update with any changes. 

Using Wages and Salaries as an example: 

1. Using the CONSOLIDATION worksheet, click in B5.  Type an “=” sign to start off a 
formula. 

2. Click on the DODGY BROS worksheet tab and select B5 (the first wages amount). 

3. Type a “+” sign 

4. Click on the SWEET TOOTH CAFÉ worksheet tab and select B5 (the first salaries 
amount) 

5. Either click on the green  or hit ENTER on the keyboard to finalise. 

6. Use the fill handle to drag this formula across to February and March (see page 14 
for details about the Fill Handle) 

7. When you have finished inputting all the consolidated figures, check the final totals 
agree with the final totals of the first two worksheets. 

For more practice try the Concatenation exercise in the Advanced Excel Exercises.xls 
workbook, on the Text and Concatenation worksheet. 
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WORKING WITH DATES 

Dates are stored as numbers in spreadsheets and because of this you can do calculations 
using dates.  Take the number 36500.35 for example.  The integer component (36500) is 
the date and the decimal fraction (.35) is the time.  The integer number is the number of 
days since 01/01/1900.  The number 36500.35 therefore, would be 6 December 1999, 
8.24am. 

By going to the TOOLS, OPTIONS menu and clicking on the CALCULATION tab you can 
enable the 1904 DATE SYSTEM option which calculates all dates from January 1, 1904. 

When you enter a date into a cell in a worksheet Excel formats that cell as a date format.  
If you then try and put a normal number into that cell, it will appear as a date.  This is 
because the formatting information and the data are stored separately in spreadsheets.  
To correct the situation you need to reformat the cell as a number (FORMAT, CELLS, 
NUMBER) or clear the format (EDIT, CLEAR, FORMATS).  You can also use the shortcut 
key to return a cell to GENERAL format – CTRL + SHIFT + ~ (a tilde). 

NOTES: If you are typing a date into a cell, you can use either / or – (slashes or 
hyphens) as separators.  E.g. 31/12/99  or 31-12-99 do the same formatting. 

 If entering a date with the year between 1920 and 2029, you only need enter the 
last two digits.  Before or after these years, enter the four numbers for the date 
to appear correctly. 

 The easiest way to enter a quantity of dates in a row or column is to use the 
EDIT, FILL, SERIES command.  You can then make the dates appear in Day, 
Weekday, Month or Year series.  Alternatively you can use the fill handle (pages 
14 to 17) with the Right Mouse Button to select a series of dates. 

 CTRL + ; is a shortcut for entering the current date. 

 A cell with a date can be reformatted to appear the way you want by going to 
FORMAT, CELLS,  DATE (for pre-designed formats) or FORMAT, CELLS, 
CUSTOM to design your own format.  The following table shows some of the 
different ways of formatting a date – using 6 August 2004 as an example: 

 

m/d 8/6 

d/m 6/8 

d/m/yy 11/8/04 

dd/mm/yy 06/08/04 

d-mmm 6 Aug 

d-mmmm 6 August 

dddd d mmmm yyyy Friday 6 August 2004 
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Useful Date Functions 

There are many DATE functions available but some common ones are: 

DATE Returns a serial number that represents a particular date.  The result is 
formatted to appear as a date.  This function is most often used when creating 
a date from values in a spreadsheet.  Calculations can be performed on these 
dates because they are stored as a serial number 

 Syntax:  =DATE(year,month,day) 

 Example:  

   

 NOTE:  If you enter an invalid month e.g. 14, Excel assumes you wish to use 
February (12 months + extra 2 months into the new year).  If you enter an 
invalid day such as 45, Excel will add that number to the first day of the 
month. 

 Example: DATE(2004,14,45) would return 17 March 2005.  (1st February 
2004 + 45 days). 

DAY Returns a number as a value corresponding to the day in a date – numbers 
range between 1 and 31.  Useful if you need to extract the day so as to 
perform calculations. 

Syntax:  DAY(serial_number) 

Example: Two examples are given, the first where the formula refers to a cell 
containing a date, the other where the date is used in the formula 
itself – Note that the date is enclosed in double quotation marks.  If 
the quotation marks were not there Excel would attempt to take 17 
and divide by 12, then the result would be divided by 1979. 
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MONTH Returns a number as a value corresponding to the month in a date – numbers 
range between 1 and 12.  Useful if you need to extract the month so as to 
perform calculations. 

Syntax:  MONTH(serial_number) 

Example: Two examples are given, the first where the formula refers to a cell 
containing a date, the other where the date is used in the formula 
itself – Note that the date is enclosed in double quotation marks.  If 
the quotation marks were not there Excel would attempt to take 17 
and divide by 12, then the result would be divided by 1979. 

 

 
 
YEAR Returns a number as a value corresponding to the year in a date – numbers 

range between 1900 and 9999.  Useful if you need to extract the year so as to 
perform calculations. 

Syntax:  YEAR(serial_number) 

Example: Two examples are given, the first where the formula refers to a cell 
containing a date, the other where the date is used in the formula 
itself – Note that the date is enclosed in double quotation marks.  If 
the quotation marks were not there Excel would attempt to take 17 
and divide by 12, then the result would be divided by 1979. 

 

TODAY: Returns the current date.  Useful for inserting into a spreadsheet where the 
current date is required.  This function does not require any arguments.  The 
date updates everytime a calculation is made in the worksheet. 

 Syntax:  =TODAY() 

 Example: 
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NOW: Returns the current date and time.  This function does not require any 
arguments.  The date and time update everytime a change is made in the 
worksheet. 

 Syntax:  =NOW() 

 Example: 
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ROUNDING FUNCTIONS 

Numbers can be rounded to decimal places by using the INCREASE or DECREASE 
DECIMAL on the Formatting toolbar or the FORMAT, CELLS, NUMBER option, however 
you are not changing the value of the number when you use these, only the display.  For 
example, if you have 123.654 decreased to 123.65, you will see 123.65 in the worksheet 
but 123.654 in the address bar.  Excel will use the underlying value (123.654) to do any 
calculations, not the displayed value. 

 

 

ROUND Rounds a number to a specific number of decimal places.  It is made up of 2 
arguments, the reference to a number and the number of decimal places 
that reference is to be rounded to.   

 Syntax: =ROUND(number,num_digits) 

 Notes: The number argument can be a number, a cell address referring 
to a cell that holds a number, or a formula which results in a 
number. 

  The num_digits argument can be a negative or positive integer 
(whole number).  If you use a negative number it rounds that 
number of places to the left of the decimal point.  If you use 0 
(zero), it number rounds to the nearest whole number.   

  Numbers less than 5 get rounded down.  Numbers that are 5 or 
more get rounded up. 

 Examples:  
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Assuming that Cell A1 holds the number 2365.854, using the 
ROUND formula in the following ways will return: 

 =ROUND(A1,0) 2366 
 =ROUND(A1,1) 2365.9 
 =ROUND(A1,2) 2365.85 
 =ROUND(A1,3) 2365.854 
 =ROUND(A1,-2) 2400 

 A number can be used as the Number argument e,g: 

 =ROUND(2365.854,-3) would return 2000 

ROUNDDOWN Works in the same way as ROUND, however as its name suggests, this 
function rounds down. 

 Syntax: =ROUNDDOWN(number,num_digits) 

 Examples: Assuming that Cell A1 holds the number 2365.854, using the 
ROUNDDOWN formula in the following ways will return:  

 =ROUNDDOWN(A1,0) 2365 
 =ROUNDDOWN(A1,1) 2365.8 
 =ROUNDDOWN(A1,2) 2365.85 
 =ROUNDDOWN(A1,3) 2365.854 
 =ROUNDDOWN(A1,-2) 2300 

ROUNDUP Works in the same way as ROUND, however as its name suggests, this 
function rounds up. 

 Syntax: =ROUNDUP(number,num_digits) 

 Examples: Assuming that Cell A1 holds the number 2365.854, using the 
ROUNDUP formula in the following ways will return:  

 =ROUNDUP(A1,0) 2366 
 =ROUNDUP(A1,1) 2365.9 
 =ROUNDUP(A1,2) 2365.86 
 =ROUNDUP(A1,3) 2365.854 
 =ROUNDUP(A1,-2) 2400 

EVEN Using this function a number can be rounded up to the nearest even integer 
or down to the nearest even negative integer. 

 Syntax: =EVEN(number) 

 Examples: =EVEN(13.6)   14 
=EVEN(16.2)   18 
=EVEN(16)    16 
=EVEN(-3)    -4 
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ODD This function rounds a number up to the nearest odd integer or down to the 
nearest odd negative integer. 

 Syntax: =ODD(number) 

 Examples: =ODD(13.6)    15 
=ODD(16.2)    17 
=ODD(17)    17 
=ODD(-4)    -5 

CEILING The CEILING function rounds a number up to the nearest specified multiple.  
This is a useful function for rounding someone’s wages to the nearest 5 
cents for example, since 1 and 2 cent pieces have been discontinued. 

 Syntax: =CEILING(number,multiple) 

 Examples: =CEILING(2365.81,.05) 2365.85 
 =CEILING(2365.81,-.05) #NUM! 
 =CEILING(-2365.81,-.05) -2365.85 

 Note: The number argument and the multiple argument must have 
the same sign or the function will return a #NUM! error. 

FLOOR The FLOOR function rounds a number down to the nearest specified 
multiple.    

 Syntax: =FLOOR (number,multiple) 

 Examples: =FLOOR(2365.81,.05) 2365.80 
 =FLOOR(2365.81,-.05) #NUM! 
 =FLOOR(-2365.81,-.05) -2365.80 

 Note: The number argument and the multiple argument must have 
the same sign or the function will return a #NUM! error. 

INT The INT function rounds numbers down to the nearest integer. 

 Syntax: =INT(number) 

 Example: =INT(2365.80) 2365 

 

TRUNC The TRUNC functions truncates numbers to the right of the decimal point. 

 Syntax: TRUNC(number,num_digits) num_digits is optional 

 Example: =TRUNC(2365.8045) 2365 
=TRUNC(2365.8045,2) 2365.80 
=TRUNC(2365.8045,1) 2365.8  
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APPENDIX 1 - FUNCTION KEYS 

 
The following lists contain function key, CTRL combination shortcut keys and some 

other common shortcut keys, along with descriptions of their functionality. 

 

Function Keys 

 

Key Description 

F1 

Displays the Microsoft Office Excel Help task pane.  

CTRL+F1 displays or hides the ribbon. 

ALT+F1 creates a chart of the data in the current range. 

ALT+SHIFT+F1 inserts a new worksheet. 

F2 

Edits the active cell and positions the insertion point at the end of the cell 

contents. It also moves the insertion point into the Formula Bar when editing 

in a cell is turned off.  

SHIFT+F2 adds or edits a cell comment. 

CTRL+F2 displays the Print Preview window. 

F3 
Displays the Paste Name dialog box.  

SHIFT+F3 displays the Insert Function dialog box. 

F4 
Repeats the last command or action, if possible.  

CTRL+F4 closes the selected workbook window. 

F5 
Displays the Go To dialog box.  

CTRL+F5 restores the window size of the selected workbook window. 

F6 

Switches between the worksheet, ribbon, task pane, and Zoom controls. In a 

worksheet that has been split (View menu, Manage This Window, Freeze 

Panes, Split Window command), F6 includes the split panes when switching 

between panes and the ribbon area.  

SHIFT+F6 switches between the worksheet, Zoom controls, task pane, and 

ribbon. 

CTRL+F6 switches to the next workbook window when more than one 

workbook window is open. 
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F7 

Displays the Spelling dialog box to check spelling in the active worksheet or 

selected range.  

CTRL+F7 performs the Move command on the workbook window when it is 

not maximized. Use the arrow keys to move the window, and when finished 

press ENTER, or ESC to cancel. 

F8 

Turns extend mode on or off. In extend mode, Extended Selection appears 

in the status line, and the arrow keys extend the selection.  

SHIFT+F8 enables you to add a nonadjacent cell or range to a selection of 

cells by using the arrow keys. 

CTRL+F8 performs the Size command (on the Control menu for the 

workbook window) when a workbook is not maximized. 

ALT+F8 displays the Macro dialog box to create, run, edit, or delete a macro. 

F9 

Calculates all worksheets in all open workbooks.  

SHIFT+F9 calculates the active worksheet. 

CTRL+ALT+F9 calculates all worksheets in all open workbooks, regardless of 

whether they have changed since the last calculation. 

CTRL+ALT+SHIFT+F9 rechecks dependent formulas, and then calculates all 

cells in all open workbooks, including cells not marked as needing to be 

calculated. 

CTRL+F9 minimizes a workbook window to an icon. 

F10 

Turns key tips on or off.  

SHIFT+F10 displays the shortcut menu for a selected item. 

ALT+SHIFT+F10 displays the menu or message for a smart tag. If more than 

one smart tag is present, it switches to the next smart tag and displays its 

menu or message. 

CTRL+F10 maximizes or restores the selected workbook window. 

F11 

Creates a chart of the data in the current range.  

SHIFT+F11 inserts a new worksheet. 

ALT+F11 opens the Microsoft Visual Basic Editor, in which you can create a 

macro by using Visual Basic for Applications (VBA). 

F12 Displays the Save As dialog box. 
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CTRL Combination Shortcut Keys 

 

Key Description 

CTRL+SHIFT+( Unhides any hidden rows within the selection. 

CTRL+SHIFT+) Unhides any hidden columns within the selection. 

CTRL+SHIFT+& Applies the outline border to the selected cells. 

CTRL+SHIFT_ Removes the outline border from the selected cells. 

CTRL+SHIFT+~ Applies the General number format. 

CTRL+SHIFT+$ 
Applies the Currency format with two decimal places (negative 

numbers in parentheses). 

CTRL+SHIFT+% Applies the Percentage format with no decimal places. 

CTRL+SHIFT+^ Applies the Exponential number format with two decimal places. 

CTRL+SHIFT+# Applies the Date format with the day, month, and year. 

CTRL+SHIFT+@ Applies the Time format with the hour and minute, and AM or PM. 

CTRL+SHIFT+! 
Applies the Number format with two decimal places, thousands 

separator, and minus sign (-) for negative values. 

CTRL+SHIFT+* 

Selects the current region around the active cell (the data area 

enclosed by blank rows and blank columns).  

In a PivotTable, it selects the entire PivotTable report. 

CTRL+SHIFT+: Enters the current time. 

CTRL+SHIFT+" 
Copies the value from the cell above the active cell into the cell or 

the Formula Bar. 

CTRL+SHIFT+Plus 

(+) 
Displays the Insert dialog box to insert blank cells. 

CTRL+Minus (-) Displays the Delete dialog box to delete the selected cells. 

CTRL+; Enters the current date. 

CTRL+` 
Alternates between displaying cell values and displaying formulas 

in the worksheet. 

CTRL+' 
Copies a formula from the cell above the active cell into the cell 

or the Formula Bar. 
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CTRL+1 Displays the Format Cells dialog box. 

CTRL+2 Applies or removes bold formatting. 

CTRL+3 Applies or removes italic formatting. 

CTRL+4 Applies or removes underlining. 

CTRL+5 Applies or removes strikethrough. 

CTRL+6 
Alternates between hiding objects, displaying objects, and 

displaying placeholders for objects. 

CTRL+8 Displays or hides the outline symbols. 

CTRL+9 Hides the selected rows. 

CTRL+0 Hides the selected columns. 

CTRL+A 

Selects the entire worksheet.  

If the worksheet contains data, CTRL+A selects the current 

region. Pressing CTRL+A a second time selects the current region 

and its summary rows. Pressing CTRL+A a third time selects the 

entire worksheet. 

When the insertion point is to the right of a function name in a 

formula, displays the Function Arguments dialog box. 

CTRL+SHIFT+A inserts the argument names and parentheses 

when the insertion point is to the right of a function name in a 

formula. 

CTRL+B Applies or removes bold formatting. 

CTRL+C 
Copies the selected cells.  

CTRL+C followed by another CTRL+C displays the Clipboard. 

CTRL+D 
Uses the Fill Down command to copy the contents and format of 

the topmost cell of a selected range into the cells below. 

CTRL+F 

Displays the Find and Replace dialog box, with the Find tab 

selected.  

SHIFT+F5 also displays this tab, while SHIFT+F4 repeats the last 

Find action. 

CTRL+SHIFT+F opens the Format Cells dialog box with the Font 

tab selected. 

CTRL+G  
Displays the Go To dialog box.  

F5 also displays this dialog box. 
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CTRL+H  
Displays the Find and Replace dialog box, with the Replace tab 

selected. 

CTRL+I Applies or removes italic formatting. 

CTRL+K 
Displays the Insert Hyperlink dialog box for new hyperlinks or 

the Edit Hyperlink dialog box for selected existing hyperlinks. 

CTRL+N  Creates a new, blank workbook. 

CTRL+O  
Displays the Open dialog box to open or find a file.  

CTRL+SHIFT+O selects all cells that contain comments. 

CTRL+P 

Displays the Print dialog box.  

CTRL+SHIFT+P opens the Format Cells dialog box with the Font 

tab selected. 

CTRL+R 
Uses the Fill Right command to copy the contents and format of 

the leftmost cell of a selected range into the cells to the right. 

CTRL+S 
Saves the active file with its current file name, location, and file 

format. 

CTRL+T Displays the Create Table dialog box. 

CTRL+U 

Applies or removes underlining.  

CTRL+SHIFT+U switches between expanding and collapsing of 

the formula bar.  

CTRL+V  

Inserts the contents of the Clipboard at the insertion point and 

replaces any selection. Available only after you have cut or copied 

an object, text, or cell contents. 

CTRL+W Closes the selected workbook window. 

CTRL+X  Cuts the selected cells. 

CTRL+Y Repeats the last command or action, if possible. 

CTRL+Z 

Uses the Undo command to reverse the last command or to 

delete the last entry that you typed.  

CTRL+SHIFT+Z uses the Undo or Redo command to reverse or 

restore the last automatic correction when AutoCorrect Smart 

Tags are displayed. 

 




